<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<base href="https://www.crowdstrike.com/blog" />

<meta charset="UTF-8" />


<title>I Know What You Did Last Month: A New Artifact of Execution on macOS 10.13</title>
<meta name="viewport" content="width=device-width, initial-scale=1">


<!-- This site is optimized with the Yoast SEO plugin v7.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Learn about a new artifact, CoreAnalytics, that can help forensic investigators determine what executed on macOS systems."/>
<link rel="canonical" href="https://www.crowdstrike.com/blog/i-know-what-you-did-last-month-a-new-artifact-of-execution-on-macos-10-13/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="I Know What You Did Last Month: A New Artifact of Execution on macOS 10.13" />
<meta property="og:description" content="Learn about a new artifact, CoreAnalytics, that can help forensic investigators determine what executed on macOS systems." />
<meta property="og:url" content="https://www.crowdstrike.com/blog/i-know-what-you-did-last-month-a-new-artifact-of-execution-on-macos-10-13/" />
<meta property="article:tag" content="featured" />
<meta property="article:tag" content="Home Feature" />
<meta property="article:section" content="From The Front Lines" />
<meta property="article:published_time" content="2018-07-24T21:38:45+00:00" />
<meta property="article:modified_time" content="2018-07-25T15:28:47+00:00" />
<meta property="og:updated_time" content="2018-07-25T15:28:47+00:00" />
<meta property="og:image" content="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog.jpg" />
<meta property="og:image:width" content="530" />
<meta property="og:image:height" content="349" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maps.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />



<link rel='stylesheet' id='js_composer_front-css'  href='https://www.crowdstrike.com/blog/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.11.1' type='text/css' media='all' />
<link rel='stylesheet' id='symple_shortcode_styles-css'  href='https://www.crowdstrike.com/blog/wp-content/plugins/symple-shortcodes/shortcodes/css/symple_shortcodes_styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.crowdstrike.com/blog/wp-content/themes/Total/style.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto-css'  href='https://www.crowdstrike.com/blog/wp-content/themes/CrowdStrike_Blog/prettyPhoto.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='wpex-font-awesome-css'  href='https://www.crowdstrike.com/blog/wp-content/themes/Total/css/lib/font-awesome.min.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpex-style-css'  href='https://www.crowdstrike.com/blog/wp-content/themes/CrowdStrike_Blog/style.css?ver=3.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpex-visual-composer-css'  href='https://www.crowdstrike.com/blog/wp-content/themes/Total/css/wpex-visual-composer.css?ver=3.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpex-visual-composer-extend-css'  href='https://www.crowdstrike.com/blog/wp-content/themes/Total/css/wpex-visual-composer-extend.css?ver=3.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-css'  href='https://www.crowdstrike.com/blog/wp-content/plugins/ubermenu/pro/assets/css/ubermenu.min.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-white-css'  href='https://www.crowdstrike.com/blog/wp-content/plugins/ubermenu/pro/assets/css/skins/white.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-font-awesome-css'  href='https://www.crowdstrike.com/blog/wp-content/plugins/ubermenu/assets/css/fontawesome/css/font-awesome.min.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpex-responsive-css'  href='https://www.crowdstrike.com/blog/wp-content/themes/Total/css/wpex-responsive.css?ver=3.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpex-agent-skin-css'  href='https://www.crowdstrike.com/blog/wp-content/themes/Total/skins/classes/agent/css/agent-style.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.crowdstrike.com/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<link rel='https://api.w.org/' href='https://www.crowdstrike.com/blog/wp-json/' />

 

<link rel='shortlink' href='https://www.crowdstrike.com/blog/?p=21053' />


<style id="ubermenu-custom-generated-css">
/** UberMenu Custom Menu Styles (Customizer) **/
/* main */
.ubermenu-main .ubermenu-item-layout-image_left > .ubermenu-target-text { padding-left:310px; }
.ubermenu-main .ubermenu-item-layout-image_right > .ubermenu-target-text { padding-right:310px; }
.ubermenu-main .ubermenu-item-level-0 > .ubermenu-target { font-size:15px; color:#494949; }
.ubermenu.ubermenu-main .ubermenu-item-level-0:hover > .ubermenu-target, .ubermenu-main .ubermenu-item-level-0.ubermenu-active > .ubermenu-target { color:#ec3525; background-color:#ffffff; background:-webkit-gradient(linear,left top,left bottom,from(#ffffff),to(#ffffff)); background:-webkit-linear-gradient(top,#ffffff,#ffffff); background:-moz-linear-gradient(top,#ffffff,#ffffff); background:-ms-linear-gradient(top,#ffffff,#ffffff); background:-o-linear-gradient(top,#ffffff,#ffffff); background:linear-gradient(top,#ffffff,#ffffff); }
.ubermenu-main .ubermenu-item-level-0.ubermenu-current-menu-item > .ubermenu-target, .ubermenu-main .ubermenu-item-level-0.ubermenu-current-menu-parent > .ubermenu-target, .ubermenu-main .ubermenu-item-level-0.ubermenu-current-menu-ancestor > .ubermenu-target { color:#ec3525; }
.ubermenu-main .ubermenu-item.ubermenu-item-level-0 > .ubermenu-highlight { color:#ec3525; }
.ubermenu.ubermenu-main .ubermenu-item-level-0 > .ubermenu-target { background-color:#ffffff; background:-webkit-gradient(linear,left top,left bottom,from(#ffffff),to(#ffffff)); background:-webkit-linear-gradient(top,#ffffff,#ffffff); background:-moz-linear-gradient(top,#ffffff,#ffffff); background:-ms-linear-gradient(top,#ffffff,#ffffff); background:-o-linear-gradient(top,#ffffff,#ffffff); background:linear-gradient(top,#ffffff,#ffffff); }
.ubermenu-main .ubermenu-submenu .ubermenu-item-header > .ubermenu-target, .ubermenu-main .ubermenu-tab > .ubermenu-target { font-size:15px; }
.ubermenu-main .ubermenu-item-normal > .ubermenu-target { color:#7a7a7a; font-size:13px; }


/** UberMenu Custom Menu Item Styles (Menu Item Settings) **/
/* 16371 */ .ubermenu .ubermenu-item-16371 > .ubermenu-target.ubermenu-item-layout-image_left > .ubermenu-target-text { padding-left:10px; }
/* 16369 */ .ubermenu .ubermenu-item-16369 > .ubermenu-target.ubermenu-item-layout-image_left > .ubermenu-target-text { padding-left:310px; }


/** UberMenu Custom Tweaks (General Settings) **/
.ubermenu-skin-white {
    border-top: none;
    border-bottom: none;
    border-left: none;
    border-right: none;
}
.ubermenu .ubermenu-image {
    max-height: 120px !important;
    display: block;
    width: 100%;
    transition: opacity 1s ease;
    opacity: 1;
overflow:hidden;
}
.ubermenu .ubermenu-image img {
height:100%;
}
.ubermenu .ubermenu-autocolumn, .ubermenu .ubermenu-submenu-type-stack {
    padding-top: 0px;
    padding-bottom: 10px;
}


/**TABS**/
.ubermenu-main .ubermenu-tab > .ubermenu-target {
    border-left:3px solid #c9c9c9;
}

.ubermenu-main .ubermenu-tab.tab-endpoint-protection > .ubermenu-target {
border-left:3px solid #ec3525;
}
.ubermenu-main .ubermenu-tab.tab-executive-viewpoint > .ubermenu-target {
border-left:3px solid #5c5c5c;
}
.ubermenu-main .ubermenu-tab.tab-front-lines > .ubermenu-target {
border-left:3px solid #bacc4d;
}

.ubermenu-main .ubermenu-tab.tab-research-intel > .ubermenu-target {
border-left:3px solid #2e8baa;
}
.ubermenu-main .ubermenu-tab.tab-tech-center > .ubermenu-target {
border-left:3px solid #eeb71c;
}
.ubermenu-main .ubermenu-tab.tab-engineering > .ubermenu-target {
border-left:3px solid #3e53d5;
}


/* Status: Loaded from Transient */

</style><!--[if IE 8]><link rel="stylesheet" type="text/css" href="https://www.crowdstrike.com/blog/wp-content/themes/Total/css/ie8.css" media="screen"><![endif]--><!--[if IE 9]><link rel="stylesheet" type="text/css" href="https://www.crowdstrike.com/blog/wp-content/themes/Total/css/ie9.css" media="screen"><![endif]--><!--[if lt IE 9]><script src="https://www.crowdstrike.com/blog/wp-content/themes/Total/js/html5.js"></script><![endif]-->
<link rel="shortcut icon" href="">
<link rel="apple-touch-icon-precomposed" href="">
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="">
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="">
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="">
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.crowdstrike.com/blog/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://www.crowdstrike.com/blog/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->		<style type="text/css" id="wp-custom-css">
			#top-bar-content {
	float:right;
	margin-right:4px;
	padding-top:2px;
}		</style>
	<style type="text/css" data-type="vc_custom-css">code, .blog-code-font {
    font-family: "Courier New", Courier, "Lucida Sans Typewriter", "Lucida Typewriter", monospace;
    color: #acacac;
}
.blog-post-code-wrapper {
    font-family: "Courier New", Courier, "Lucida Sans Typewriter", "Lucida Typewriter", monospace;
    overflow-x: scroll;
    max-width: 730px;
    color: #000 !important;
    background-color: #dcdcdc;
    padding: 10px;
}
.table-bordered > tbody > tr > td {
    padding:4px 8px;
    border-color:#f68b3e;
}
tr.top-row > td {
    background-color: #f68b3e;
    color:#ffffff;
}</style><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><!-- TOTAL CSS -->
<style type="text/css">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</style>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<link href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">
<!-- Standard Favicon -->
  <link rel="icon" type="image/x-icon" href="/wp-content/img/favicon/favicon.ico">

<!-- For iPhone 4 Retina display: -->
  <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/img/favicon/apple-icon-114x114.png">

<!-- For iPad: -->
  <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/img/favicon/apple-icon-72x72.png">

<!-- For iPhone: -->
  <link rel="apple-touch-icon-precomposed" href="/wp-content/img/favicon/apple-icon-57x57.png">

<link rel="stylesheet" type="text/css" href="https://cloud.typography.com/6483816/6935392/css/fonts.css" />
<link rel="stylesheet" href="/blog/wp-content/css/blog.css">

<script type="text/javascript" src="/wp-content/custom_js/plugins/jquery.flip.min.js"></script>
<script type="text/javascript" async src="/wp-content/custom_js/plugins/jquery.easing.1.3.min.js"></script>
<script type="text/javascript" src="/wp-content/custom_js/plugins/jquery.easing.1.3.wrapped.min.js"></script>
<script type="text/javascript" src="/wp-content/themes/CrowdStrike_Theme/js/jquery.prettyPhoto.js?ver=1.0.0"></script>
<script type="text/javascript" src="/wp-content/custom_js/plugins/jquery.backstretch.min.js"></script>
<script type="text/javascript" src="/wp-content/custom_js/plugins/jquery.cj-swipe.js"></script>
<script type="text/javascript" async src="/blog/wp-content/custom_js/jquery-base.js"></script>
<script type="text/javascript" src="/wp-content/custom_js/jquery.cornerslider.min.js"></script>
<!-- Page-hiding snippet (recommended) -->
<style>.async-hide { opacity: 0 !important} </style>
<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
(a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
})(window,document.documentElement,'async-hide','dataLayer',4000,
{'GTM-N8HXDD2':true});</script>
<!-- Modified Analytics tracking code with Optimize plugin -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
 
ga('create', 'UA-25861131-13', 'auto');
ga('require', 'GTM-N8HXDD2');
ga('send', 'pageview');
</script>
</head>

<!-- Begin Body -->
<body class="post-template-default single single-post postid-21053 single-format-standard custom-background symple-shortcodes  symple-shortcodes-responsive wpex-theme wpex-responsive full-width-main-layout skin-agent has-composer wpex-live-site has-sidebar content-right-sidebar post-in-category-from-the-front-lines has-topbar sidebar-widget-icons page-header-disabled wpex-mobile-toggle-menu-icon_buttons has-mobile-menu wpb-js-composer js-comp-ver-4.11.1 vc_responsive">

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W4TT8S"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<!-- contact us modal -->
<div id="modal-wrapper" style="display:none;">
    <div id="modal-overlay"></div>
    <div id="modal">
        <div id="modal-content" class="page-section form modal">
            <a id="modal-close">X</a>

            <iframe id="form-frame" src="https://go.crowdstrike.com/NewsAndComms.html" width="100%" height="100%">
            </iframe>
        </div>
    </div>
</div>


<!-- EU Cookie Opt In -->
<script type="application/javascript" src="/wp-content/custom_js/set_tracking.js"></script>
<div id="optInMessage" style="display:none;">
    <p>This website uses cookies to enhance your browsing experience. Please note that by continuing to use this site you consent to the terms of our <a href="/privacy-notice">Privacy Notice.</a>
    <div class="btn btn-large btn-bordered border-white bg-red white hover-to-red" id="opt-in-btn"><span>ACCEPT</span></div>
</div>
<!-- End EU cookie opt in -->



<script>
  (function() {
    var cx = '013138164481186672820:gn0-cvkk8ja';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>

<script type="application/javascript">
    $( document ).ready(function() {
        $('#top-bar').append("<gcse:search></gcse:search>");
        /* $('li#menu-item-14540').empty().append("<gcse:search></gcse:search>"); */
        setTimeout(function(){
            document.getElementById('gsc-i-id1').setAttribute('placeholder','Search');
            document.getElementById('gsc-i-id2').setAttribute('placeholder','Search');
        }, 1500);
    });
</script>

<!--- <script type="application/javascript">
$(document).ready(function() {

  if (!(/careers/.test(window.location.href))) {
    $('iframe').each(function() {
        var originalsrc = $(this).attr('src') + '?';
        var newsrc = originalsrc.concat(window.location.search.substring(1));
        $(this).attr('src', newsrc);
    });
  }

});

</script> -->

<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);
 
  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };
 
  return t;
}(document, "script", "twitter-wjs"));</script>


<span data-ls_id="#site_top"></span>
<div id="outer-wrap" class="clr">

	
	<div id="wrap" class="clr">

		

	<div id="top-bar-wrap" class="clr wpex-top-bar-sticky hidden-phone">

		<div id="top-bar" class="clr container">

			
	<div id="top-bar-content" class="wpex-clr has-content top-bar-left">

		
		
			<div style="float: right; margin-right: 150px;">
<img class="cs-search-icon desktop" src="/wp-content/themes/CrowdStrike_Theme/images/search.png">
</div>

<div class="search-wrapper" style="display: none;"><input type="text" id="addsearchfield" class="addsearch" disabled="disabled" /></div>

		
	</div><!-- #top-bar-content -->

			
			

<div id="top-bar-social" class="clr top-bar-right social-style-none">

	<a href="https://twitter.com/CrowdStrike" title="Twitter" class="wpex-twitter wpex-social-btn wpex-social-btn-no-style" target="_blank"><span class="fa fa-twitter"></span></a><a href="https://www.facebook.com/CrowdStrike" title="Facebook" class="wpex-facebook wpex-social-btn wpex-social-btn-no-style" target="_blank"><span class="fa fa-facebook"></span></a><a href="https://plus.google.com/101967380457820256808" title="Google Plus" class="wpex-googleplus wpex-social-btn wpex-social-btn-no-style" target="_blank"><span class="fa fa-google-plus"></span></a><a href="https://www.linkedin.com/company/crowdstrike" title="LinkedIn" class="wpex-linkedin wpex-social-btn wpex-social-btn-no-style" target="_blank"><span class="fa fa-linkedin"></span></a><a href="https://www.youtube.com/user/CrowdStrike" title="Youtube" class="wpex-youtube wpex-social-btn wpex-social-btn-no-style" target="_blank"><span class="fa fa-youtube"></span></a><a href="mailto:info@crowdstrike.com" title="Email" class="wpex-email wpex-social-btn wpex-social-btn-no-style" target="_blank"><span class="fa fa-envelope"></span></a>
</div><!-- #top-bar-social -->
		</div><!-- #top-bar -->

	</div><!-- #top-bar-wrap -->



<header id="site-header" class="header-one fixed-scroll dyn-styles clr">

	
	<div id="site-header-inner" class="container clr">

		        <!-- UberMenu Content Before --><div id="site-logo" class="site-branding clr header-one-logo">
<div id="site-logo-inner" class="clr">
<a id="cs-blog-nav-logo" href="https://www.crowdstrike.com/" title="CrowdStrike" rel="" class="site-logo-text"></a>
<a href="https://www.crowdstrike.com/blog/" title="CrowdStrike Blog" rel="home" class="blog-logo-text avant-light"><span class="avant-xbold">BLOG</span></a>
</div>
</div><!-- End UberMenu Content Before -->
<!-- UberMenu [Configuration:main] [Theme Loc:] [Integration:api] -->
<nav id="ubermenu-main-77" class="ubermenu ubermenu-nojs ubermenu-main ubermenu-menu-77 ubermenu-responsive ubermenu-responsive-single-column ubermenu-responsive-default ubermenu-responsive-collapse ubermenu-horizontal ubermenu-transition-none ubermenu-trigger-hover_intent ubermenu-skin-white  ubermenu-bar-align-right ubermenu-items-align-left ubermenu-disable-submenu-scroll ubermenu-sub-indicators ubermenu-retractors-responsive"><ul id="ubermenu-nav-main-77" class="ubermenu-nav"><li id="menu-item-16342" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-16342 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/featured-articles/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Featured</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-16342 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[16369] count[4] --><li class=" ubermenu-autocolumn menu-item-16369-col-0 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16369-col-0"><ul class="ubermenu-submenu ubermenu-submenu-id-16369-col-0 ubermenu-submenu-type-stack" ><li id="menu-item-16369-post-21092" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16369 ubermenu-item-16369-post-21092 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/meet-crowdstrikes-adversary-of-the-month-for-july-wicked-spider/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog-300x198.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog.jpg 530w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="120" alt="Wicked-Spider-Blog"  /><span class="ubermenu-target-title ubermenu-target-text">Meet CrowdStrike’s Adversary of the Month for July: WICKED SPIDER</span><span class="ubermenu-target-description ubermenu-target-text">July 26, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16369-col-1 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16369-col-1"><ul class="ubermenu-submenu ubermenu-submenu-id-16369-col-1 ubermenu-submenu-type-stack" ><li id="menu-item-16369-post-21045" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16369 ubermenu-item-16369-post-21045 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/why-cybersecurity-should-be-a-board-level-discussion/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2-300x198.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2.jpg 530w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="120" alt="Shawn-Henry-Photo-blog2"  /><span class="ubermenu-target-title ubermenu-target-text">Why Cybersecurity Should be a Board-Level Discussion</span><span class="ubermenu-target-description ubermenu-target-text">July 25, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16369-col-2 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16369-col-2"><ul class="ubermenu-submenu ubermenu-submenu-id-16369-col-2 ubermenu-submenu-type-stack" ><li id="menu-item-16369-post-21053" class="ubermenu-current-menu-item ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16369 ubermenu-item-16369-post-21053 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/i-know-what-you-did-last-month-a-new-artifact-of-execution-on-macos-10-13/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog-300x198.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog.jpg 530w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="120" alt="macOS-artifact-blog"  /><span class="ubermenu-target-title ubermenu-target-text">I Know What You Did Last Month: A New Artifact of Execution on macOS 10.13</span><span class="ubermenu-target-description ubermenu-target-text">July 24, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16369-col-3 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16369-col-3"><ul class="ubermenu-submenu ubermenu-submenu-id-16369-col-3 ubermenu-submenu-type-stack" ><li id="menu-item-16369-post-21022" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16369 ubermenu-item-16369-post-21022 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/global-survey-reveals-supply-chain-as-a-rising-and-critical-new-threat-vector/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5-300x198.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5.jpg 530w" sizes="(max-width: 300px) 100vw, 300px" width="300" height="120" alt="supplychainimage5"  /><span class="ubermenu-target-title ubermenu-target-text">Global Survey Reveals Supply Chain as a Rising and Critical New Threat Vector</span><span class="ubermenu-target-description ubermenu-target-text">July 23, 2018</span></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[16369] --></ul></li><li id="menu-item-16343" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-16343 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/recent-articles/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Recent</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-16343 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[16371] count[4] --><li class=" ubermenu-autocolumn menu-item-16371-col-0 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16371-col-0"><ul class="ubermenu-submenu ubermenu-submenu-id-16371-col-0 ubermenu-submenu-type-stack" ><li id="menu-item-16371-post-21092" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16371 ubermenu-item-16371-post-21092 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/meet-crowdstrikes-adversary-of-the-month-for-july-wicked-spider/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog-300x198.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog.jpg 530w" sizes="(max-width: 300px) 100vw, 300px" height="120" alt="Wicked-Spider-Blog"  /><span class="ubermenu-target-title ubermenu-target-text">Meet CrowdStrike’s Adversary of the Month for July: WICKED SPIDER</span><span class="ubermenu-target-description ubermenu-target-text">July 26, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16371-col-1 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16371-col-1"><ul class="ubermenu-submenu ubermenu-submenu-id-16371-col-1 ubermenu-submenu-type-stack" ><li id="menu-item-16371-post-21045" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16371 ubermenu-item-16371-post-21045 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/why-cybersecurity-should-be-a-board-level-discussion/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2-300x198.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2.jpg 530w" sizes="(max-width: 300px) 100vw, 300px" height="120" alt="Shawn-Henry-Photo-blog2"  /><span class="ubermenu-target-title ubermenu-target-text">Why Cybersecurity Should be a Board-Level Discussion</span><span class="ubermenu-target-description ubermenu-target-text">July 25, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16371-col-2 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16371-col-2"><ul class="ubermenu-submenu ubermenu-submenu-id-16371-col-2 ubermenu-submenu-type-stack" ><li id="menu-item-16371-post-21053" class="ubermenu-current-menu-item ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16371 ubermenu-item-16371-post-21053 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/i-know-what-you-did-last-month-a-new-artifact-of-execution-on-macos-10-13/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog-300x198.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog.jpg 530w" sizes="(max-width: 300px) 100vw, 300px" height="120" alt="macOS-artifact-blog"  /><span class="ubermenu-target-title ubermenu-target-text">I Know What You Did Last Month: A New Artifact of Execution on macOS 10.13</span><span class="ubermenu-target-description ubermenu-target-text">July 24, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16371-col-3 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16371-col-3"><ul class="ubermenu-submenu ubermenu-submenu-id-16371-col-3 ubermenu-submenu-type-stack" ><li id="menu-item-16371-post-21022" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16371 ubermenu-item-16371-post-21022 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/global-survey-reveals-supply-chain-as-a-rising-and-critical-new-threat-vector/"><img class="ubermenu-image ubermenu-image-size-medium" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5-300x198.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5.jpg 530w" sizes="(max-width: 300px) 100vw, 300px" height="120" alt="supplychainimage5"  /><span class="ubermenu-target-title ubermenu-target-text">Global Survey Reveals Supply Chain as a Rising and Critical New Threat Vector</span><span class="ubermenu-target-description ubermenu-target-text">July 23, 2018</span></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[16371] --></ul></li><li id="menu-item-16344" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-16344 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/videos/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Videos</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-16344 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[16372] count[4] --><li class=" ubermenu-autocolumn menu-item-16372-col-0 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16372-col-0"><ul class="ubermenu-submenu ubermenu-submenu-id-16372-col-0 ubermenu-submenu-type-stack" ><li id="menu-item-16372-post-17038" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16372 ubermenu-item-16372-post-17038 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/power-of-the-platform-spring-release-extends-the-crowdstrike-falcon-platform/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2016/05/CrowdStrike-spring-2016-release.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2016/05/CrowdStrike-spring-2016-release.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2016/05/CrowdStrike-spring-2016-release-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="CrowdStrike spring 2016 release"  /><span class="ubermenu-target-title ubermenu-target-text">The Power of The Platform: Spring Release Extends The CrowdStrike Falcon Platform</span><span class="ubermenu-target-description ubermenu-target-text">May 25, 2016</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16372-col-1 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16372-col-1"><ul class="ubermenu-submenu ubermenu-submenu-id-16372-col-1 ubermenu-submenu-type-stack" ><li id="menu-item-16372-post-2459" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16372 ubermenu-item-16372-post-2459 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/cant-protect-your-data-from-ransomware-think-again/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2016/02/ransomware.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2016/02/ransomware.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2016/02/ransomware-300x198.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2016/02/ransomware-150x99.jpg 150w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="ransomware"  /><span class="ubermenu-target-title ubermenu-target-text">Can&#8217;t Protect Your Data from Ransomware? Think Again.</span><span class="ubermenu-target-description ubermenu-target-text">February 24, 2016</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16372-col-2 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16372-col-2"><ul class="ubermenu-submenu ubermenu-submenu-id-16372-col-2 ubermenu-submenu-type-stack" ><li id="menu-item-16372-post-2025" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16372 ubermenu-item-16372-post-2025 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/brian-kelly-cso-of-rackspace-shares-why-he-chose-crowdstrike/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2015/08/rackspace-screenie.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2015/08/rackspace-screenie.jpg 852w, https://www.crowdstrike.com/blog/wp-content/uploads/2015/08/rackspace-screenie-300x168.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2015/08/rackspace-screenie-768x429.jpg 768w" sizes="(max-width: 852px) 100vw, 852px" width="300" height="200" alt="rackspace-screenie"  /><span class="ubermenu-target-title ubermenu-target-text">Brian Kelly, CSO of Rackspace, Shares Why He Chose CrowdStrike</span><span class="ubermenu-target-description ubermenu-target-text">August 14, 2015</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16372-col-3 ubermenu-item-level-2 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16372-col-3"><ul class="ubermenu-submenu ubermenu-submenu-id-16372-col-3 ubermenu-submenu-type-stack" ><li id="menu-item-16372-post-1914" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16372 ubermenu-item-16372-post-1914 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-2 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/avoiding-the-cyber-security-blindside-cardinal-innovations-talks-endpoint-security/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2015/05/cardinal-innovations-video-screenie.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2015/05/cardinal-innovations-video-screenie.jpg 956w, https://www.crowdstrike.com/blog/wp-content/uploads/2015/05/cardinal-innovations-video-screenie-300x169.jpg 300w, https://www.crowdstrike.com/blog/wp-content/uploads/2015/05/cardinal-innovations-video-screenie-768x431.jpg 768w" sizes="(max-width: 956px) 100vw, 956px" width="300" height="200" alt="cardinal-innovations-video-screenie"  /><span class="ubermenu-target-title ubermenu-target-text">Avoiding the Cyber Security Blindside: Cardinal Innovation&#8217;s CIO Talks Endpoint Protection</span><span class="ubermenu-target-description ubermenu-target-text">May 21, 2015</span></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[16372] --></ul></li><li id="menu-item-16345" class="menu-categories ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-16345 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/categories/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Categories</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-16345 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Tabs: [Tabs] 18427 --><li id="menu-item-18427" class="ubermenu-tabs menu-item-18427 ubermenu-item-level-1 ubermenu-column ubermenu-column-full ubermenu-tab-layout-left ubermenu-tabs-show-default"><ul class="ubermenu-tabs-group ubermenu-column ubermenu-column-1-4 ubermenu-submenu ubermenu-submenu-id-18427 ubermenu-submenu-type-auto ubermenu-submenu-type-tabs-group" ><li id="menu-item-18428" class="ubermenu-tab tab-endpoint-protection ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-18428 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/category/endpoint-protection"><span class="ubermenu-target-title ubermenu-target-text">Endpoint Protection</span></a><ul class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-3-4 ubermenu-submenu ubermenu-submenu-id-18428 ubermenu-submenu-type-auto ubermenu-submenu-type-tab-content-panel" ><li id="menu-item-16532" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-has-children ubermenu-item-16532 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-stack" ><div class="ubermenu-content-block ubermenu-custom-content ubermenu-custom-content-padded"><div class="category-nav">
<span>
<i class="cs-icon-category-bullseye red"></i>
<a class="grey" href="/blog/category/endpoint-protection/">ENDPOINT PROTECTION</a>
</span>
<hr style="border:1px solid #ec3525;">
</div></div><ul class="ubermenu-submenu ubermenu-submenu-id-16532 ubermenu-submenu-type-auto ubermenu-submenu-type-stack" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[16374] count[4] --><li class=" ubermenu-autocolumn menu-item-16374-col-0 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16374-col-0"><ul class="ubermenu-submenu ubermenu-submenu-id-16374-col-0 ubermenu-submenu-type-stack" ><li id="menu-item-16374-post-21022" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16374 ubermenu-item-16374-post-21022 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/global-survey-reveals-supply-chain-as-a-rising-and-critical-new-threat-vector/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/supplychainimage5-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="supplychainimage5"  /><span class="ubermenu-target-title ubermenu-target-text">Global Survey Reveals Supply Chain as a Rising and Critical New Threat Vector</span><span class="ubermenu-target-description ubermenu-target-text">July 23, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16374-col-1 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16374-col-1"><ul class="ubermenu-submenu ubermenu-submenu-id-16374-col-1 ubermenu-submenu-type-stack" ><li id="menu-item-16374-post-21006" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16374 ubermenu-item-16374-post-21006 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/crowdstrike-falcon-discover-for-aws-visibility-that-ensures-security-in-the-cloud/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/FalconDiscover-AWS-blog.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/FalconDiscover-AWS-blog.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/FalconDiscover-AWS-blog-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="FalconDiscover-AWS-blog"  /><span class="ubermenu-target-title ubermenu-target-text">CrowdStrike Falcon Discover for AWS: Visibility That Ensures Security in The Cloud</span><span class="ubermenu-target-description ubermenu-target-text">July 17, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16374-col-2 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16374-col-2"><ul class="ubermenu-submenu ubermenu-submenu-id-16374-col-2 ubermenu-submenu-type-stack" ><li id="menu-item-16374-post-20977" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16374 ubermenu-item-16374-post-20977 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/getting-the-most-out-of-your-free-trial-of-next-gen-antivirus/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Free-Trial-Guide-blog.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Free-Trial-Guide-blog.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Free-Trial-Guide-blog-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="Free-Trial-Guide-blog"  /><span class="ubermenu-target-title ubermenu-target-text">Getting The Most Out of Your Free Trial of Next-Gen Antivirus</span><span class="ubermenu-target-description ubermenu-target-text">July 11, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16374-col-3 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16374-col-3"><ul class="ubermenu-submenu ubermenu-submenu-id-16374-col-3 ubermenu-submenu-type-stack" ><li id="menu-item-16374-post-20969" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16374 ubermenu-item-16374-post-20969 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/sc-magazine-names-crowdstrike-falcon-a-best-buy-with-five-stars-across-all-categories/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/SC-Mag-blog-3.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/SC-Mag-blog-3.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/SC-Mag-blog-3-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="SC-Mag-blog-3"  /><span class="ubermenu-target-title ubermenu-target-text">SC Magazine Names CrowdStrike Falcon a “Best Buy” with Five Stars Across All Categories</span><span class="ubermenu-target-description ubermenu-target-text">July 6, 2018</span></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[16374] --></ul></li></ul></li><li id="menu-item-18429" class="ubermenu-tab tab-executive-viewpoint ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-18429 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/category/executive-viewpoint/"><span class="ubermenu-target-title ubermenu-target-text">Executive Viewpoint</span></a><ul class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-3-4 ubermenu-submenu ubermenu-submenu-id-18429 ubermenu-submenu-type-auto ubermenu-submenu-type-tab-content-panel" ><li id="menu-item-16546" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-has-children ubermenu-item-16546 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-stack" ><div class="ubermenu-content-block ubermenu-custom-content ubermenu-custom-content-padded"><div class="category-nav">
<span>
<i class="cs-icon-bullseye-target grey"></i>
<a class="grey" href="/blog/category/executive-viewpoint/">EXECUTIVE VIEWPOINT</a>
</span>
<hr style="border:1px solid #bcbdc1;">
</div></div><ul class="ubermenu-submenu ubermenu-submenu-id-16546 ubermenu-submenu-type-auto ubermenu-submenu-type-stack" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[16547] count[4] --><li class=" ubermenu-autocolumn menu-item-16547-col-0 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16547-col-0"><ul class="ubermenu-submenu ubermenu-submenu-id-16547-col-0 ubermenu-submenu-type-stack" ><li id="menu-item-16547-post-21045" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16547 ubermenu-item-16547-post-21045 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/why-cybersecurity-should-be-a-board-level-discussion/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Shawn-Henry-Photo-blog2-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="Shawn-Henry-Photo-blog2"  /><span class="ubermenu-target-title ubermenu-target-text">Why Cybersecurity Should be a Board-Level Discussion</span><span class="ubermenu-target-description ubermenu-target-text">July 25, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16547-col-1 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16547-col-1"><ul class="ubermenu-submenu ubermenu-submenu-id-16547-col-1 ubermenu-submenu-type-stack" ><li id="menu-item-16547-post-20892" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16547 ubermenu-item-16547-post-20892 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/why-australia-shouldnt-ignore-north-koreas-cyber-regime/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/05/The-Australian-2.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/05/The-Australian-2.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/05/The-Australian-2-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="The-Australian-2"  /><span class="ubermenu-target-title ubermenu-target-text">Why Australia Shouldn’t Ignore North Korea’s Cyber Regime</span><span class="ubermenu-target-description ubermenu-target-text">June 25, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16547-col-2 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16547-col-2"><ul class="ubermenu-submenu ubermenu-submenu-id-16547-col-2 ubermenu-submenu-type-stack" ><li id="menu-item-16547-post-20863" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16547 ubermenu-item-16547-post-20863 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/crowdstrike-closes-200-million-series-e-financing-round-with-new-and-existing-investors/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/series-e.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/series-e.jpg 536w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/series-e-300x195.jpg 300w" sizes="(max-width: 536px) 100vw, 536px" width="300" height="200" alt="series-e"  /><span class="ubermenu-target-title ubermenu-target-text">CrowdStrike Announces $200 Million Series E Financing Round with New and Existing Investors</span><span class="ubermenu-target-description ubermenu-target-text">June 19, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16547-col-3 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16547-col-3"><ul class="ubermenu-submenu ubermenu-submenu-id-16547-col-3 ubermenu-submenu-type-stack" ><li id="menu-item-16547-post-20831" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16547 ubermenu-item-16547-post-20831 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/crowdstrike-honored-as-best-enterprise-security-solution-in-sc-awards-europe/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/SC-Award-Europe-Blog.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/SC-Award-Europe-Blog.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/SC-Award-Europe-Blog-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="SC-Award-Europe-Blog"  /><span class="ubermenu-target-title ubermenu-target-text">CrowdStrike Honored as Best Enterprise Security Solution in SC Awards Europe</span><span class="ubermenu-target-description ubermenu-target-text">June 12, 2018</span></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[16547] --></ul></li></ul></li><li id="menu-item-18430" class="ubermenu-tab tab-front-lines ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-18430 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/category/from-the-front-lines/"><span class="ubermenu-target-title ubermenu-target-text">From The Front Lines</span></a><ul class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-3-4 ubermenu-submenu ubermenu-submenu-id-18430 ubermenu-submenu-type-auto ubermenu-submenu-type-tab-content-panel" ><li id="menu-item-16542" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-has-children ubermenu-item-16542 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-stack" ><div class="ubermenu-content-block ubermenu-custom-content ubermenu-custom-content-padded"><div class="category-nav">
<span>
<i class="cs-icon-category-triangle-alert limegreen"></i>
<a class="grey" href="/blog/category/from-the-front-lines/">FROM THE FRONT LINES</a>
</span>
<hr style="border:1px solid #bacc4d;">
</div></div><ul class="ubermenu-submenu ubermenu-submenu-id-16542 ubermenu-submenu-type-auto ubermenu-submenu-type-stack" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[16539] count[4] --><li class=" ubermenu-autocolumn menu-item-16539-col-0 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16539-col-0"><ul class="ubermenu-submenu ubermenu-submenu-id-16539-col-0 ubermenu-submenu-type-stack" ><li id="menu-item-16539-post-21053" class="ubermenu-current-menu-item ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16539 ubermenu-item-16539-post-21053 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/i-know-what-you-did-last-month-a-new-artifact-of-execution-on-macos-10-13/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="macOS-artifact-blog"  /><span class="ubermenu-target-title ubermenu-target-text">I Know What You Did Last Month: A New Artifact of Execution on macOS 10.13</span><span class="ubermenu-target-description ubermenu-target-text">July 24, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16539-col-1 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16539-col-1"><ul class="ubermenu-submenu ubermenu-submenu-id-16539-col-1 ubermenu-submenu-type-stack" ><li id="menu-item-16539-post-21025" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16539 ubermenu-item-16539-post-21025 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/visit-crowdstrike-at-black-hat-2018/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Black-hat-booth.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Black-hat-booth.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Black-hat-booth-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="Black-hat-booth"  /><span class="ubermenu-target-title ubermenu-target-text">Visit CrowdStrike at Black Hat 2018</span><span class="ubermenu-target-description ubermenu-target-text">July 20, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16539-col-2 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16539-col-2"><ul class="ubermenu-submenu ubermenu-submenu-id-16539-col-2 ubermenu-submenu-type-stack" ><li id="menu-item-16539-post-20986" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16539 ubermenu-item-16539-post-20986 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/spark-hot-potato-passing-dataframes-between-scala-spark-and-pyspark/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Python-blog-image.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Python-blog-image.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Python-blog-image-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="PySpark"  /><span class="ubermenu-target-title ubermenu-target-text">Spark Hot Potato: Passing DataFrames Between Scala Spark and PySpark</span><span class="ubermenu-target-description ubermenu-target-text">July 13, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16539-col-3 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16539-col-3"><ul class="ubermenu-submenu ubermenu-submenu-id-16539-col-3 ubermenu-submenu-type-stack" ><li id="menu-item-16539-post-20849" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16539 ubermenu-item-16539-post-20849 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/hiding-in-plain-sight-using-the-office-365-activities-api-to-investigate-business-email-compromises/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/Hiding-plain-sight-blog.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/Hiding-plain-sight-blog.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/Hiding-plain-sight-blog-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="Hiding-plain-sight-blog"  /><span class="ubermenu-target-title ubermenu-target-text">Hiding in Plain Sight: Using the Office 365 Activities API to Investigate Business Email Compromises</span><span class="ubermenu-target-description ubermenu-target-text">June 18, 2018</span></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[16539] --></ul></li></ul></li><li id="menu-item-18431" class="ubermenu-tab tab-research-intel ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-18431 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/category/threat-intel-research/"><span class="ubermenu-target-title ubermenu-target-text">Research &#038; Threat Intel</span></a><ul class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-3-4 ubermenu-submenu ubermenu-submenu-id-18431 ubermenu-submenu-type-auto ubermenu-submenu-type-tab-content-panel" ><li id="menu-item-16544" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-has-children ubermenu-item-16544 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-stack" ><div class="ubermenu-content-block ubermenu-custom-content ubermenu-custom-content-padded"><div class="category-nav">
<span>
<i class="cs-icon-category-shield teal"></i>
<a class="grey" href="/blog/category/threat-intel-research/">RESEARCH & THREAT INTEL</a>
</span>
<hr style="border: 1px solid #2e8baa;">
</div></div><ul class="ubermenu-submenu ubermenu-submenu-id-16544 ubermenu-submenu-type-auto ubermenu-submenu-type-stack" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[16541] count[4] --><li class=" ubermenu-autocolumn menu-item-16541-col-0 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16541-col-0"><ul class="ubermenu-submenu ubermenu-submenu-id-16541-col-0 ubermenu-submenu-type-stack" ><li id="menu-item-16541-post-21092" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16541 ubermenu-item-16541-post-21092 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/meet-crowdstrikes-adversary-of-the-month-for-july-wicked-spider/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Wicked-Spider-Blog-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="Wicked-Spider-Blog"  /><span class="ubermenu-target-title ubermenu-target-text">Meet CrowdStrike’s Adversary of the Month for July: WICKED SPIDER</span><span class="ubermenu-target-description ubermenu-target-text">July 26, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16541-col-1 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16541-col-1"><ul class="ubermenu-submenu ubermenu-submenu-id-16541-col-1 ubermenu-submenu-type-stack" ><li id="menu-item-16541-post-20844" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16541 ubermenu-item-16541-post-20844 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/meet-crowdstrikes-adversary-of-the-month-for-june-mustang-panda/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/Mustan-Panda-Blog-Image.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/Mustan-Panda-Blog-Image.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/Mustan-Panda-Blog-Image-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="Mustan-Panda-Blog-Image"  /><span class="ubermenu-target-title ubermenu-target-text">Meet CrowdStrike’s Adversary of the Month for June: MUSTANG PANDA</span><span class="ubermenu-target-description ubermenu-target-text">June 15, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16541-col-2 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16541-col-2"><ul class="ubermenu-submenu ubermenu-submenu-id-16541-col-2 ubermenu-submenu-type-stack" ><li id="menu-item-16541-post-20726" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16541 ubermenu-item-16541-post-20726 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/adversary-of-the-month-for-may/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/05/Mthic-Leopard-May.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/05/Mthic-Leopard-May.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/05/Mthic-Leopard-May-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="Mthic-Leopard-May"  /><span class="ubermenu-target-title ubermenu-target-text">Meet CrowdStrike’s Adversary of the Month for May: MYTHIC LEOPARD</span><span class="ubermenu-target-description ubermenu-target-text">May 18, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-16541-col-3 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-16541-col-3"><ul class="ubermenu-submenu ubermenu-submenu-id-16541-col-3 ubermenu-submenu-type-stack" ><li id="menu-item-16541-post-20474" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-16541 ubermenu-item-16541-post-20474 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/meet-crowdstrikes-adversary-of-the-month-for-april-stardust-chollima/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/04/April-Adversary-Stardust.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2018/04/April-Adversary-Stardust.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2018/04/April-Adversary-Stardust-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="April-Adversary-Stardust"  /><span class="ubermenu-target-title ubermenu-target-text">Meet CrowdStrike’s Adversary of the Month for April: STARDUST CHOLLIMA</span><span class="ubermenu-target-description ubermenu-target-text">April 6, 2018</span></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[16541] --></ul></li></ul></li><li id="menu-item-18432" class="ubermenu-tab tab-tech-center ubermenu-item ubermenu-item-type-custom ubermenu-item-object-custom ubermenu-item-has-children ubermenu-item-18432 ubermenu-item-auto ubermenu-column ubermenu-column-full ubermenu-has-submenu-drop" data-ubermenu-trigger="mouseover" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="/blog/category/tech-center/"><span class="ubermenu-target-title ubermenu-target-text">Tech Center</span></a><ul class="ubermenu-tab-content-panel ubermenu-column ubermenu-column-3-4 ubermenu-submenu ubermenu-submenu-id-18432 ubermenu-submenu-type-auto ubermenu-submenu-type-tab-content-panel" ><li id="menu-item-17163" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-has-children ubermenu-item-17163 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-3 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-stack" ><div class="ubermenu-content-block ubermenu-custom-content ubermenu-custom-content-padded"><div class="category-nav">
<span>
<i class="cs-icon-resources-community-tools tech-orange"></i>
<a class="grey" href="/blog/tech-center/">TECH CENTER</a>
</span>
<hr style="border:1px solid #eeb71c;">
</div></div><ul class="ubermenu-submenu ubermenu-submenu-id-17163 ubermenu-submenu-type-auto ubermenu-submenu-type-stack" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[17164] count[4] --><li class=" ubermenu-autocolumn menu-item-17164-col-0 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-17164-col-0"><ul class="ubermenu-submenu ubermenu-submenu-id-17164-col-0 ubermenu-submenu-type-stack" ><li id="menu-item-17164-post-18454" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-17164 ubermenu-item-17164-post-18454 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/tech-center/falcon-protects-off-line-hosts-from-new-threats/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="CrowdStrike Tech Center"  /><span class="ubermenu-target-title ubermenu-target-text">How CrowdStrike Falcon Protects Off-line Endpoints</span><span class="ubermenu-target-description ubermenu-target-text">January 27, 2017</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-17164-col-1 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-17164-col-1"><ul class="ubermenu-submenu ubermenu-submenu-id-17164-col-1 ubermenu-submenu-type-stack" ><li id="menu-item-17164-post-20287" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-17164 ubermenu-item-17164-post-20287 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/tech-center/crowdstrike-falcon-uses-powerful-platform-simplify-deployment-enhance-security/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="CrowdStrike Tech Center"  /><span class="ubermenu-target-title ubermenu-target-text">How CrowdStrike&#8217;s Powerful Platform Simplifies Deployment and Enhances Security</span><span class="ubermenu-target-description ubermenu-target-text">February 5, 2018</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-17164-col-2 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-17164-col-2"><ul class="ubermenu-submenu ubermenu-submenu-id-17164-col-2 ubermenu-submenu-type-stack" ><li id="menu-item-17164-post-17464" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-17164 ubermenu-item-17164-post-17464 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/tech-center/falcon-overwatch-proactively-hunts-threats-environment/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="CrowdStrike Tech Center"  /><span class="ubermenu-target-title ubermenu-target-text">How Falcon OverWatch Proactively Hunts for Threats in Your Environment</span><span class="ubermenu-target-description ubermenu-target-text">July 27, 2016</span></a></li></ul></li><li class=" ubermenu-autocolumn menu-item-17164-col-3 ubermenu-item-level-5 ubermenu-column ubermenu-column-1-4 ubermenu-has-submenu-stack ubermenu-item-type-column ubermenu-column-id-17164-col-3"><ul class="ubermenu-submenu ubermenu-submenu-id-17164-col-3 ubermenu-submenu-type-stack" ><li id="menu-item-17164-post-17467" class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-17164 ubermenu-item-17164-post-17467 ubermenu-item-auto ubermenu-item-normal ubermenu-item-level-5 ubermenu-column ubermenu-column-auto" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.crowdstrike.com/blog/tech-center/falcon-overwatch-works-breach-attempt-discovered/"><img class="ubermenu-image ubermenu-image-size-full" src="https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter.jpg" srcset="https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter.jpg 530w, https://www.crowdstrike.com/blog/wp-content/uploads/2016/07/TechCenter-300x198.jpg 300w" sizes="(max-width: 530px) 100vw, 530px" width="300" height="200" alt="CrowdStrike Tech Center"  /><span class="ubermenu-target-title ubermenu-target-text">How Falcon OverWatch Works with You When a Breach Attempt is Discovered</span><span class="ubermenu-target-description ubermenu-target-text">July 27, 2016</span></a></li></ul></li><!-- end Dynamic Posts: [Dynamic Posts] ID[17164] --></ul></li></ul></li></ul></li><!-- end Tabs: [Tabs] 18427 --></ul></li></ul></nav>
<!-- End UberMenu -->

<div id="site-logo" class="site-branding clr header-one-logo">
	<div id="site-logo-inner" class="clr">
					<a href="https://www.crowdstrike.com/blog/" title="" rel="home" class="site-logo-text"></a>
			</div><!-- #site-logo-inner -->
</div><!-- #site-logo -->
	
	<div id="site-navigation-wrap" class="navbar-style-one wpex-dropdowns-caret clr">

		<nav id="site-navigation" class="navigation main-navigation clr">

			
				<ul id="menu-main-menu" class="dropdown-menu sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-16342"><a href="/blog/featured-articles/"><span class="link-inner">Featured</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-16369"><a href="#ubermenu-dynamic_posts"><span class="link-inner">[Dynamic Posts]</span></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-16343"><a href="/blog/recent-articles/"><span class="link-inner">Recent</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-16371"><a href="#ubermenu-dynamic_posts"><span class="link-inner">[Dynamic Posts]</span></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-16344"><a href="/blog/videos/"><span class="link-inner">Videos</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-16372"><a href="#ubermenu-dynamic_posts"><span class="link-inner">[Dynamic Posts]</span></a></li>
</ul>
</li>
<li class="menu-categories menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-16345"><a href="/blog/categories/"><span class="link-inner">Categories</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-has-children dropdown menu-item-18427"><a href="#ubermenu-tabs"><span class="link-inner">[Tabs]</span></a>
	<ul class="sub-menu">
		<li class="tab-endpoint-protection menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-18428"><a href="/blog/category/endpoint-protection"><span class="link-inner">Endpoint Protection</span></a>
		<ul class="sub-menu">
			<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-has-children dropdown menu-item-16532"><a href="#ubermenu-custom_content"><span class="link-inner">[Custom]</span></a>
			<ul class="sub-menu">
				<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-16374"><a href="#ubermenu-dynamic_posts"><span class="link-inner">[Dynamic Posts]</span></a></li>
			</ul>
</li>
		</ul>
</li>
		<li class="tab-executive-viewpoint menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-18429"><a href="/blog/category/executive-viewpoint/"><span class="link-inner">Executive Viewpoint</span></a>
		<ul class="sub-menu">
			<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-has-children dropdown menu-item-16546"><a href="#ubermenu-custom_content"><span class="link-inner">[Custom]</span></a>
			<ul class="sub-menu">
				<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-16547"><a href="#ubermenu-dynamic_posts"><span class="link-inner">[Dynamic Posts]</span></a></li>
			</ul>
</li>
		</ul>
</li>
		<li class="tab-front-lines menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-18430"><a href="/blog/category/from-the-front-lines/"><span class="link-inner">From The Front Lines</span></a>
		<ul class="sub-menu">
			<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-has-children dropdown menu-item-16542"><a href="#ubermenu-custom_content"><span class="link-inner">[Custom]</span></a>
			<ul class="sub-menu">
				<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-16539"><a href="#ubermenu-dynamic_posts"><span class="link-inner">[Dynamic Posts]</span></a></li>
			</ul>
</li>
		</ul>
</li>
		<li class="tab-research-intel menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-18431"><a href="/blog/category/threat-intel-research/"><span class="link-inner">Research &#038; Threat Intel</span></a>
		<ul class="sub-menu">
			<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-has-children dropdown menu-item-16544"><a href="#ubermenu-custom_content"><span class="link-inner">[Custom]</span></a>
			<ul class="sub-menu">
				<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-16541"><a href="#ubermenu-dynamic_posts"><span class="link-inner">[Dynamic Posts]</span></a></li>
			</ul>
</li>
		</ul>
</li>
		<li class="tab-tech-center menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-18432"><a href="/blog/category/tech-center/"><span class="link-inner">Tech Center</span></a>
		<ul class="sub-menu">
			<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-has-children dropdown menu-item-17163"><a href="#ubermenu-custom_content"><span class="link-inner">[Custom]</span></a>
			<ul class="sub-menu">
				<li class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-17164"><a href="#ubermenu-dynamic_posts"><span class="link-inner">[Dynamic Posts]</span></a></li>
			</ul>
</li>
		</ul>
</li>
	</ul>
</li>
</ul>
</li>
</ul>
			
		</nav><!-- #site-navigation -->

	</div><!-- #site-navigation-wrap -->

	

<div id="mobile-menu" class="clr wpex-mobile-menu-toggle wpex-hidden">
			<a href="#" class="mobile-menu-toggle"><span class="fa fa-navicon"></span></a>
		</div><!-- #mobile-menu -->
	</div><!-- #site-header-inner -->

	
</header><!-- #header -->


		
		<main id="main" class="site-main clr">

			
	<div id="content-wrap" class="container clr">

		
		<div id="primary" class="content-area clr">

			
			<div id="content" class="site-content clr">

				
				
<article class="single-blog-article clr">


	
<header class="single-blog-header clr">
	<h1 class="single-post-title entry-title">I Know What You Did Last Month: A New Artifact of Execution on macOS 10.13</h1><!-- .single-post-title -->
</header><!-- .blog-single-header -->
<ul class="meta clr">

	
					<li class="meta-date"><span class="fa fa-clock-o"></span><time class="updated" datetime="2018-07-24">July 24, 2018</time></li>
		
		
		
		
	
		
					<li class="meta-author"><span class="fa fa-user"></span><span class="vcard author"><span class="fn"><a href="https://www.crowdstrike.com/blog/author/kshitij-kumar-and-jai-musunuri/" title="Posts by Kshitij Kumar and Jai Musunuri" rel="author">Kshitij Kumar and Jai Musunuri</a></span></span></li>
		
		
		
	
		
		
					<li class="meta-category"><span class="fa fa-folder-o"></span><a href="https://www.crowdstrike.com/blog/category/from-the-front-lines/" rel="category tag">From The Front Lines</a></li>
		
		
	
</ul><!-- .meta -->
	<div id="post-media" class="clr">

					<img src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/macOS-artifact-blog.jpg" width="530" height="349" alt="MacOS Artifact Blog" itemprop="image" />		
		
	</div><!-- #post-media -->


<div class="entry clr">
	
<div class="wpex-vc-row-wrap clr">

	<div class="vc_row wpb_row vc_row-fluid">

		
			<div class="wpex-vc-columns-wrap clr">				<div class="wpb_column vc_column_container vc_col-sm-12"><div class="vc_column-inner wpex-clr"><div class="wpb_wrapper wpex-vc-column-wrapper wpex-clr ">
	<div class="wpb_text_column wpb_content_element ">
		<div class="wpb_wrapper">
			<h3><strong>Introduction</strong></h3>
<p>Analysts that perform macOS forensics have had few, if any, artifacts of program execution to rely on during investigations — until now. In macOS 10.13 (High Sierra), Apple introduced CoreAnalytics, which is a system diagnostics mechanism that maintains a record of Mach-O programs that have executed on a system over approximately one month. CoreAnalytics can serve a number of valuable analytical purposes for both insider threat investigations and incident response. The artifact can be used to:</p>
<ul>
<li>Determine the extent to which a system was in use, with accuracy up to one day</li>
<li>Determine which programs were run on a particular day, whether in the foreground or in the background</li>
<li>Determine how long, approximately, a program was running and/or active, as well as provide an approximate number of times the program was launched or brought to the foreground interactively</li>
</ul>
<p>This article provides a technical overview and analysis of the CoreAnalytics artifacts found in macOS 10.13, as well as a means for investigators to parse this artifact into a more digestible format.</p>
<h3><strong>Summary Analysis</strong></h3>
<p>The CoreAnalytics artifact provides a historical and current perspective on program execution, on a near-daily basis. This data is derived from two sources:</p>
<ul>
<li>Files with the extension<code> .core_analytics</code> in <code>/Library/Logs/DiagnosticReports/</code> that are comprised of JSON records: The first two records can be parsed to reveal the timestamps that the diagnostic period began and ended; the data following those records indicates system and application usage over the diagnostic period.</li>
<li>Files with GUID-like names in <code>/private/var/db/analyticsd/aggregates/</code> that are comprised of nested arrays: The subsystems that report to the analytics daemon temporarily stage program execution data in these aggregate files, for the current diagnostic period. The staged data is typically pushed to a <code>.core_analytics</code> file at the end of the diagnostic period.</li>
</ul>
<p>The diagnostic period is defined within the <code>.core_analytics</code> files within the first two lines, which establish the times that the period began and ended. Each diagnostic period ends at the first system sleep or shutdown after 00:00:00 UTC. As mentioned above, data for the day is staged in aggregate files before being submitted to a <code>.core_analytics</code> file for longer-term storage at the end of the diagnostic period. Consequently, CoreAnalytics cannot be used to determine the exact time that a program was executed, but can be used to determine the time frame (approximately within a 24-hour period) in which the program was run.</p>
<p>In light of this artifact, we have written a <a href="https://github.com/CrowdStrike/Forensics/tree/master/CoreAnalyticsParser" target="_blank" rel="noopener">Python script (available on our public GitHub)</a> that will parse both CoreAnalytics and aggregates files and write the results to a more easily consumable JSON or CSV. The CoreAnalyticsParser script will:</p>
<ul>
<li>Parse and convert the diagnostic period start and end timestamps into UTC and the ISO8601 format for each <code>.core_analytics</code> file</li>
<li>Extract the relevant, available fields from each record from each available <code>.core_analytics</code> file</li>
<li>Convert raw values that have been determined to indicate a number of seconds to a more readable %H:%M:%S strftime format</li>
<li>Parse the aggregate file associated with the <code>comappleosanalyticsappUsage</code> subsystem into the same fields produced by that subsystem in each <code>.core_analytics</code> file.</li>
</ul>
<p>An application execution record may appear as below in a <code>.core_analytics</code> file:</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;message&#8217;: { &#8216;activations&#8217;: 105,<br />
&#8216;activeTime&#8217;: 4250,<br />
&#8216;activityPeriods&#8217;: 12,<br />
&#8216;appDescription&#8217;: &#8216;com.google.Chrome ||| 67.0.3396.87 (3396.87)&#8217;,<br />
&#8216;foreground&#8217;: &#8216;YES&#8217;,<br />
&#8216;idleTimeouts&#8217;: 4,<br />
&#8216;launches&#8217;: 0,<br />
&#8216;powerTime&#8217;: 12537,<br />
&#8216;processName&#8217;: &#8216;Google Chrome&#8217;,<br />
&#8216;uptime&#8217;: 26110},<br />
&#8216;name&#8217;: &#8216;comappleosanalyticsappUsage&#8217;,<br />
&#8216;uuid&#8217;: &#8216;4d7c9e4a-8c8c-4971-bce3-09d38d078849&#8217;}</div>
<p>Figure 1: CoreAnalytics record example for Google Chrome.</p>
<p>When parsed by CoreAnalyticsParser, the same record will appear as:</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;src_report&#8217;: &#8216;/path/to/Analytics_2018-06-29-173717_ML-C02PA037R9QZ.core_analytics&#8217;,<br />
&#8216;diag_start&#8217;: &#8216;2018-06-29T00:00:09Z&#8217;,<br />
&#8216;diag_end&#8217;: &#8216;2018-06-30T00:37:17.660000Z&#8217;,<br />
&#8216;name&#8217;: &#8216;comappleosanalyticsappUsage&#8217;,<br />
&#8216;uuid&#8217;: &#8216;4d7c9e4a-8c8c-4971-bce3-09d38d078849&#8217;,<br />
&#8216;processName&#8217;: &#8216;Google Chrome&#8217;,<br />
&#8216;appDescription&#8217;: &#8216;com.google.Chrome ||| 67.0.3396.87 (3396.87)&#8217;,<br />
&#8216;appName&#8217;: &#8216;com.google.Chrome&#8217;,<br />
&#8216;appVersion&#8217;: &#8216;67.0.3396.87 (3396.87)&#8217;,<br />
&#8216;foreground&#8217;: &#8216;YES&#8217;,<br />
&#8216;uptime&#8217;: &#8216;26110&#8217;,<br />
&#8216;uptime_parsed&#8217;: &#8216;7:15:10&#8217;,<br />
&#8216;powerTime&#8217;: &#8216;12537&#8217;,<br />
&#8216;powerTime_parsed&#8217;: &#8216;3:28:57&#8217;,<br />
&#8216;activeTime&#8217;: &#8216;4250&#8217;,<br />
&#8216;activeTime_parsed&#8217;: &#8216;1:10:50&#8217;,<br />
&#8216;activations&#8217;: &#8216;105&#8217;,<br />
&#8216;launches&#8217;: &#8216;0&#8217;,<br />
&#8216;activityPeriods&#8217;: &#8217;12&#8217;,<br />
&#8216;idleTimeouts&#8217;: &#8216;4&#8217;}</div>
<p>Figure 2: The CoreAnalytics record from Fig. 1, parsed into JSON by the CoreAnalyticsParser script.</p>
<p><strong>NOTE:</strong> The parsed example above is in JSON format, which can be optionally generated with the script with the use of the -j flag. By default, the script will output the same data in CSV format.</p>
<p>The script can run on a live system or run against a directory that contains either CoreAnalytics or aggregate files.</p>
<h3><strong>Technical Analysis</strong></h3>
<h4><strong>The CoreAnalytics Files</strong></h4>
<p>The <code>.core_analytics</code> files contain JSON records that indicate both program execution history and timestamps that define the particular diagnostic period in which the history data was collected. These files, which can be found in <code>/Library/Logs/DiagnosticReports/</code>, are named with the convention <code>Analytics_YYYY_MM_DD_HHMMSS_&lt;systemname&gt;.core_analytics</code>. The timestamp in the filename is based on the system’s local time. Prior to 10.13, the <code>DiagnosticReports</code> folder only contained application fault and crash reports. Now, there is execution data for applications whether they crashed or not.</p>
<p>The analytics daemon, which is responsible for producing and gathering system analytics and diagnostics data, maintains information about previously-written CoreAnalytics files in <code>/private/var/db/analyticsd</code>. In the root of the directory, the <code>currentConfiguration.json</code> file appears to maintain a dictionary of names, UUIDs and data types for the different subsystems that report to the daemon.</p>
<p>In the <code>/private/var/db/analyticsd/journals</code> directory, the <code>da2-identity.json</code> file maintains a listing of <code>_marker</code> records from recently generated CoreAnalytics files. The first entry generally predates the first available CoreAnalytics file by 7-10 days and the last entry appears to be one report behind the most recently written. Generally, this data may be used to confirm that all expected <code>.core_analytics</code> files are present and have not been tampered with.</p>
<p><strong>Defining the Diagnostic Period</strong></p>
<p>The first record in the <code>.core_analytics</code> files contains a timestamp field, where the value reflects the time that the diagnostic period ended. This timestamp is recorded in local time — but thankfully, in a timezone-aware format. If unaltered, this timestamp should match the last modified timestamp of the file. In other words, the <code>.core_analytics</code> file is only written to this location after the diagnostic period ends.</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;bug_type&#8217;: &#8216;211&#8217;,<br />
&#8216;os_version&#8217;: &#8216;Mac OS X 10.13.5 (17F77)&#8217;,<br />
&#8216;timestamp&#8217;: &#8216;2018-06-05 17:16:48.19 -0700&#8217;}</div>
<p>Figure 3: The first line of a <code>.core_analytics</code> file, with the diagnostic period end timestamp.</p>
<p>The time that the diagnostic period began can be found in the following JSON record which begins with <code>_marker.</code> The UTC timestamp is the value paired with the <code>startTimestamp</code> field.</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;_marker&#8217;: &#8221;,<br />
&#8216;_preferredUserInterfaceLanguage&#8217;: &#8216;en&#8217;,<br />
&#8216;_userInterfaceLanguage&#8217;: &#8216;en&#8217;,<br />
&#8216;_userSetRegionFormat&#8217;: &#8216;US&#8217;,<br />
&#8216;startTimestamp&#8217;: &#8216;2018-06-05T00:19:13Z&#8217;,<br />
&#8216;version&#8217;: &#8216;1.0&#8217;}</div>
<p>Figure 4: The second line of a <code>.core_analytics</code> file, with the diagnostic period start timestamp.</p>
<p>The CoreAnalytics files are written to the <code>DiagnosticReports</code> directory almost daily, with a near-perfect cutover to the next file during consecutive days of system usage. CoreAnalytics files are not generated on days that the system is asleep or shutdown for the entire diagnostic reporting period.</p>
<table class="table-striped table-bordered">
<tbody>
<tr class="bg-orange top-row">
<td><strong>Diagnostic Period Began</strong></td>
<td><strong>Diagnostic Period Ended</strong></td>
</tr>
<tr>
<td>2018-06-08T01:51:23Z</td>
<td>2018-06-09T01:50:01.370000Z</td>
</tr>
<tr>
<td>2018-06-10T16:49:09Z</td>
<td>2018-06-11T03:53:15.140000Z</td>
</tr>
<tr>
<td>2018-06-11T03:53:14Z</td>
<td>2018-06-12T02:50:17.410000Z</td>
</tr>
<tr>
<td>2018-06-12T02:50:17Z</td>
<td>2018-06-13T00:17:45.870000Z</td>
</tr>
<tr>
<td>2018-06-13T00:17:45Z</td>
<td>2018-06-14T01:17:06.340000Z</td>
</tr>
</tbody>
</table>
<p>Table 1: Example of a perfect cutover between <code>.core_analytics</code> files on consecutive days of use, and imperfect cutover when the system was not awake.</p>
<p>These files are typically generated in the <code>DiagnosticReports</code> folder daily upon the first sleep or shutdown past 00:00:00 UTC, based on our analysis of the binary plist <code>/private/var/db/analyticsd/Library/Preferences/analyticsd.plist</code>. This plist records the last submission time and next submission time of the <code>.core_analytics</code> in Unix Epoch format.</p>
<div class="blog-post-code-wrapper darker-text">Key: cadence<br />
Type: String<br />
Value:<br />
{ &#8216;bootToken&#8217;: 1530574585000000,<br />
&#8216;lastSubmission&#8217;: 1531256233,<br />
&#8216;nextSubmission&#8217;: 1531267200,<br />
&#8216;osVersion&#8217;: &#8217;17E202&#8242;,<br />
&#8216;version&#8217;: 1}</div>
<p>Figure 5: Contents of the <code>analyticsd.plist</code> that reveal last submission and next submission timestamps.</p>
<p>However, our testing shows that the report is generally written at the first sleep or shutdown after the submission time has passed.</p>
<h4><strong>System Usage</strong></h4>
<p>After the timestamp and marker records, the records produced by the <code>comappleosanalyticssystemUsage</code> subsystem reflect the uptime of the system in number of seconds. New records are likely generated by this subsystem after the machine sleeps or shuts down. The sum of the <code>uptime</code> values in these records reflects the total time that the system was awake. The <code>Uptime</code> field is simply the <code>uptime</code> value rounded down to the nearest thousand. The <code>activeTime</code> field likely indicates the amount of time, in number of seconds, that the system was actively in use while awake. The two records below suggest that the system was awake for two periods of time (approximately 4 and 40 minutes long, respectively) for a total of 44 minutes and 38 seconds, but the system was actively used for only 14 minutes and 26 seconds.</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;message&#8217;: { &#8216;Uptime&#8217;: 0,<br />
&#8216;activations&#8217;: 2,<br />
&#8216;activeTime&#8217;: 42,<br />
&#8216;idleTimeouts&#8217;: 1,<br />
&#8216;uptime&#8217;: 247},<br />
&#8216;name&#8217;: &#8216;comappleosanalyticssystemUsage&#8217;,<br />
&#8216;uuid&#8217;: &#8216;00866801-81a5-466a-a51e-a24b606ce5f1&#8217;}<br />
{ &#8216;message&#8217;: { &#8216;Uptime&#8217;: 2000,<br />
&nbsp; &nbsp; &nbsp; &nbsp; &#8216;activations&#8217;: 2,<br />
&nbsp; &nbsp; &nbsp; &nbsp; &#8216;activeTime&#8217;: 824,<br />
&nbsp; &nbsp; &nbsp; &nbsp; &#8216;idleTimeouts&#8217;: 1,<br />
&nbsp; &nbsp; &nbsp; &nbsp; &#8216;uptime&#8217;: 2431},<br />
&#8216;name&#8217;: &#8216;comappleosanalyticssystemUsage&#8217;,<br />
&#8216;uuid&#8217;: &#8216;00866801-81a5-466a-a51e-a24b606ce5f1&#8217;}</div>
<p>Figure 6: Example of two records that reveal system usage information.</p>
<p>Immediately afterward, two records appear that indicate two-hour and one-day heartbeats. The significance of these lines is yet unclear, as these heartbeats do not appear to correlate with the duration of the diagnostic period or the uptime of any of the programs recorded. The field name <code>BogusFieldNotActuallyEverUsed</code> may indicate that not only the field, but the data itself has been deprecated.</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;message&#8217;: { &#8216;BogusFieldNotActuallyEverUsed&#8217;: &#8216;null&#8217;, &#8216;Count&#8217;: 7},<br />
&#8216;name&#8217;: &#8216;TwoHourHeartbeatCount&#8217;,<br />
&#8216;uuid&#8217;: &#8216;7ad14604-ce6e-45f3-bd39-5bc186d92049&#8217;}{ &#8216;message&#8217;: { &#8216;BogusFieldNotActuallyEverUsed&#8217;: &#8216;null&#8217;, &#8216;Count&#8217;: 1},<br />
&#8216;name&#8217;: &#8216;OneDayHeartBeatCount&#8217;,<br />
&#8216;uuid&#8217;: &#8216;a4813163-fd49-44ea-b3e1-e47a015e629c&#8217;}</div>
<p>Figure 7: Heartbeat records.</p>
<h4><strong>Application Usage</strong></h4>
<p>All of the lines that follow are comprised of three keys: <code>name</code>, <code>uuid</code>, and <code>message</code>. The name and <code>uuid</code> keys map to the particular subsystem that generated the record, while the message field contains a nested JSON record that contains additional data. The most common subsystems and UUIDs that we have observed are:</p>
<table class="table-striped table-bordered">
<tbody>
<tr class="bg-orange top-row">
<td><strong>Sub-System Name</strong></td>
<td><strong>UUID</strong></td>
</tr>
<tr>
<td>comappleosanalyticsappUsage</td>
<td>4d7c9e4a-8c8c-4971-bce3-09d38d078849</td>
</tr>
<tr>
<td>comappleosanalyticssystemUsage</td>
<td>00866801-81a5-466a-a51e-a24b606ce5f1</td>
</tr>
<tr>
<td>comappleosanalyticsMASAppUsage</td>
<td>0fd0693a-3d0a-48be-bdb2-528e18a3e86c</td>
</tr>
<tr>
<td>TwoHourHeartbeatCount</td>
<td>7ad14604-ce6e-45f3-bd39-5bc186d92049</td>
</tr>
<tr>
<td>OneDayHeartBeatCount</td>
<td>a4813163-fd49-44ea-b3e1-e47a015e629c</td>
</tr>
</tbody>
</table>
<p>Table 2: Common subsystems that report to the analytics daemon and their UUIDs.</p>
<p>Our testing has shown that the UUIDs above are consistent across several systems running macOS 10.13.4 and 10.13.5. This would suggest that the UUIDs are associated exclusively with the subsystem and its particular version, and may be updated as Apple makes modifications to the subsystems in the future.</p>
<p>The <code>comappleosanalyticsappUsage</code> subsystem produces a single record per program that is executed.</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;message&#8217;: { &#8216;activations&#8217;: 105,<br />
&#8216;activeTime&#8217;: 4250,<br />
&#8216;activityPeriods&#8217;: 12,<br />
&#8216;appDescription&#8217;: &#8216;com.google.Chrome ||| 67.0.3396.87 (3396.87)&#8217;,<br />
&#8216;foreground&#8217;: &#8216;YES&#8217;,<br />
&#8216;idleTimeouts&#8217;: 4,<br />
&#8216;launches&#8217;: 0,<br />
&#8216;powerTime&#8217;: 12537,<br />
&#8216;processName&#8217;: &#8216;Google Chrome&#8217;,<br />
&#8216;uptime&#8217;: 26110},<br />
&#8216;name&#8217;: &#8216;comappleosanalyticsappUsage&#8217;,<br />
&#8216;uuid&#8217;: &#8216;4d7c9e4a-8c8c-4971-bce3-09d38d078849&#8217;}</div>
<p>Figure 8: Sample <code>.core_analytics</code> record produced by the<code> comappleosanalyticsappUsage</code> subsystem.</p>
<p>The nine fields under <code>message</code> may provide significant forensic value to an analyst.</p>
<ul>
<li><strong>activeTime</strong> likely provides the number of seconds that a program ran in the foreground.</li>
<li><strong>activityPeriods</strong> likely provides the number of instances that a program was brought to the foreground.</li>
<li><strong>appDescription</strong> is populated by data that is directly pulled from the <code>Info.plist</code> that resides within the pertinent program’s application bundle. If the requisite keys from the <code>Info.plist</code> are malformed or empty, they may appear as ???.</li>
</ul>
<p>The data is stored in the following format in the CoreAnalytics record:</p>
<div class="blog-post-code-wrapper darker-text"><span style="font-weight: 400;">&lt;CFBundleIdentifier&gt; ||| &lt;CFBundleShortVersionString&gt; (&lt;CFBundleVersion&gt;) </span></div>
<p>Figure 9: Data Format of CoreAnalytics Record</p>
<p>Below are the keys that were used to populate the record above, from the <code>Info.plist</code> located within <code>Google Chrome.app</code>.</p>
<div class="blog-post-code-wrapper darker-text">
<span style="font-weight: 400;">&lt;key&gt;CFBundleIdentifier&lt;/key&gt;</span><br />
<span style="font-weight: 400;">&lt;string&gt;com.google.Chrome&lt;/string&gt;</span><br />
<span style="font-weight: 400;">&lt;key&gt;CFBundleShortVersionString&lt;/key&gt;</span><br />
<span style="font-weight: 400;">&lt;string&gt;67.0.3396.99&lt;/string&gt;</span><br />
<span style="font-weight: 400;">&lt;key&gt;CFBundleVersion&lt;/key&gt;</span><br />
<span style="font-weight: 400;">&lt;string&gt;3396.99&lt;/string&gt;</span>
</div>
<p>Figure 10: Keys from <code>Google Chrome.app</code> <code>Info.plist</code></p>
<p>If the program was run as an independent Mach-O executable, or the <code>Info.plist</code> is either unavailable, malformed, or incomplete, the <code>appDescription</code> will appear as <code>UNBUNDLED ||| ???.</code></p>
<p>In the example below, the <code>CFBundleVersion</code> key in the GlobalProtect <code>Info.plist</code> was not populated.</p>
<div class="blog-post-code-wrapper darker-text">com.paloaltonetworks.GlobalProtect ||| 4.0.2-19 (???)</div>
<p>Figure 11: Value of <code>appDescription</code> for GlobalProtect CoreAnalytics record</p>
<ul>
<li><strong>foreground</strong> provides a <code>YES</code> or <code>NO</code> string value that indicates whether the program was run in the foreground.</li>
<li><strong>idleTimeouts</strong> purpose is unclear as of yet.</li>
<li><strong>launches </strong>likely indicates the number of times the program was launched during the diagnostic reporting period. The value of <code>launches</code> will remain at zero if the program was launched prior to the beginning of the diagnostic period.</li>
<li><strong>powerTime</strong>, based on our testing, likely reflects the number of seconds that the program was running and consuming AC power.</li>
<li><strong>processName </strong>is derived from the <code>CFBundleExecutable</code> key in the <code>Info.plist</code> that resides within the pertinent program’s application bundle.</li>
<li>Below is the key that was used to populated the CoreAnalytics record above, from the <code>Info.plist</code> located within<code> Google Chrome.app.</code></li>
</ul>
<div class="blog-post-code-wrapper darker-text">
<span style="font-weight: 400;">&lt;key&gt;CFBundleExecutable&lt;/key&gt;<br />
&lt;string&gt;Google Chrome&lt;/string&gt;</span>
</div>
<p>Figure 12: <code>CFBundleExecutable</code> Key from <code>Google Chrome.app</code> <code>Info.plist</code></p>
<p>If the program was run as an independent Mach-O executable, or the <code>Info.plist</code> is either unavailable, malformed or incomplete, this field is still populated in the CoreAnalytics record. Through our testing, we have not been able to identify the secondary source used by the analytics daemon to obtain this data.</p>
<p>In some cases, as shown below, the <code>processName</code> field will be left null. In these scenarios, it is practically impossible to determine which program’s execution has been recorded via CoreAnalytics.</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;message&#8217;: { &#8216;activations&#8217;: 0,<br />
&#8216;activeTime&#8217;: 0,<br />
&#8216;activityPeriods&#8217;: 0,<br />
&#8216;appDescription&#8217;: &#8216;UNBUNDLED ||| ???&#8217;,<br />
&#8216;foreground&#8217;: &#8216;NO&#8217;,<br />
&#8216;idleTimeouts&#8217;: 0,<br />
&#8216;launches&#8217;: 2,<br />
&#8216;powerTime&#8217;: 0,<br />
&#8216;processName&#8217;: &#8221;,<br />
&#8216;uptime&#8217;: 24},<br />
&#8216;name&#8217;: &#8216;comappleosanalyticsappUsage&#8217;,<br />
&#8216;uuid&#8217;: &#8216;4d7c9e4a-8c8c-4971-bce3-09d38d078849&#8217;}</div>
<p>Figure 13: CoreAnalytics Record for Unnamed Program</p>
<ul>
<li><strong>uptime</strong> likely reflects the total time, in number of seconds, that a program has been running. This does not include time that the system was asleep or shut down. Certain programs, such as the Dock, will have uptimes that either exactly or nearly match the total uptime of the system during the diagnostic period. In the two records from the System Usage section above, the sum of the uptimes (<code>247</code> and <code>2431</code>) exactly amounts to the uptime of the Dock application as seen below (<code>2678</code>).</li>
</ul>
<div class="blog-post-code-wrapper darker-text">{ &#8216;message&#8217;: { &#8216;activations&#8217;: 0,<br />
&#8216;activeTime&#8217;: 0,<br />
&#8216;activityPeriods&#8217;: 0,<br />
&#8216;appDescription&#8217;: &#8216;com.apple.dock ||| 1.8 (1849.16)&#8217;,<br />
&#8216;foreground&#8217;: &#8216;NO&#8217;,<br />
&#8216;idleTimeouts&#8217;: 0,<br />
&#8216;launches&#8217;: 0,<br />
&#8216;powerTime&#8217;: 0,<br />
&#8216;processName&#8217;: &#8216;Dock&#8217;,<br />
&#8216;uptime&#8217;: 2678},<br />
&#8216;name&#8217;: &#8216;comappleosanalyticsappUsage&#8217;,<br />
&#8216;uuid&#8217;: &#8216;4d7c9e4a-8c8c-4971-bce3-09d38d078849&#8217;}</div>
<p>Figure 14: CoreAnalytics Record for Dock</p>
<p>In our testing, we identified that a different subsystem, <code>comappleosanalyticsMASAppUsage</code>, wrote a record to the CoreAnalytics file for Microsoft OneNote. The nested JSON in the message key has a different structure than in records written by <code>comappleosanalyticsappUsage.</code> Rather than an <code>appDescription</code> field, this record natively divides the <code>CFBundleIdentifier</code> and the <code>CFBundleShortVersionString</code> (along with the <code>CFBundleVersion</code>) into <code>identifier</code> and <code>version</code> fields. The record also lacks all of the other message keys aside from <code>launches</code>.</p>
<div class="blog-post-code-wrapper darker-text">{ &#8216;message&#8217;: { &#8216;identifier&#8217;: &#8216;com.microsoft.onenote.mac&#8217;,<br />
&#8216;launches&#8217;: 1,<br />
&#8216;version&#8217;: &#8216;15.32 (15.32.17030400)&#8217;},<br />
&#8216;name&#8217;: &#8216;comappleosanalyticsMASAppUsage&#8217;,<br />
&#8216;uuid&#8217;: &#8216;0fd0693a-3d0a-48be-bdb2-528e18a3e86c&#8217;}</div>
<p>Figure 15: CoreAnalytics record for Microsoft OneNote, produced by a different analytics subsystem.</p>
<p><span style="font-weight: 400;">It is possible that other subsystems produce records with dissimilar data structures. </span></p>
<h4><b>Staging the Day’s Execution Data</b></h4>
<p><span style="font-weight: 400;">It is possible to recover CoreAnalytics data before it is written to the CoreAnalytics file at the end of the diagnostic period. </span></p>
<p>The <code><span style="font-weight: 400;">/private/var/db/analyticsd/aggregates/</span></code> directory<span style="font-weight: 400;"> serves as a temporary staging location for each subsystem to store analytics data, before the data must be submitted and pushed to the day’s CoreAnalytics file. The directory contains one staging file per subsystem, where the filename is the subsystem’s UUID. For example, the file </span><span style="font-weight: 400;"><code>4d7c9e4a-8c8c-4971-bce3-09d38d078849</code></span><span style="font-weight: 400;"> contains data generated by version 1.0 of the </span><code><span style="font-weight: 400;">comappleosanalyticsappUsage</span></code><span style="font-weight: 400;"> subsystem that will be written to a CoreAnalytics file in </span><code><span style="font-weight: 400;">/Library/Logs/DiagnosticReports/</span></code><span style="font-weight: 400;"> at the first sleep or shutdown after 00:00:00 UTC. The contents of these files appear to be a set of nested arrays. The array for Google Chrome, for example, appears as below:</span></p>
<div class="blog-post-code-wrapper darker-text">[ [&#8216;Google Chrome&#8217;, &#8216;com.google.Chrome ||| 67.0.3396.99 (3396.99)&#8217;, &#8216;YES&#8217;],<br />
[5660, 145, 0, 0, 5, 2, 1020]]</div>
<p>Figure 16: Aggregate data for Google Chrome.</p>
<p>The values correspond to the following fields that would normally appear in a CoreAnalytics record produced by the <code>comappleosanalyticsappUsage</code> subsystem:</p>
<div class="blog-post-code-wrapper darker-text">[ [processName, appDescription, foreground],<br />
[uptime, activeTime, launches, idleTimeouts, activations, activityPeriods, powerTime]]</div>
<p>Figure 17: Array structure for aggregate data.</p>
<p>By parsing out the array of values in an aggregate file and correlating them with the fields above, it becomes possible to analyze application usage information for the current day, before it is written out to a CoreAnalytics file.</p>
<h3><strong>Conclusion</strong></h3>
<p>CoreAnalytics provides a trove of information about the usage of a system and its applications. Program execution history that covers a month of activity can serve a crucial purpose in investigations where collection of evidence is not immediately feasible. Though documentation from Apple may provide additional clarity into the purpose of certain fields and the nature of their values, the analysis above provides a strong basis on which analysts can begin to investigate application activity on macOS systems.</p>
<p>&nbsp;</p>
<p><em>For more information on CrowdStrike&#8217;s Incident Response, Compromise Assessment or Threat Hunting offerings, visit the <a href="https://www.crowdstrike.com/services/">CrowdStrike Services page</a> or please reach out to us at: <a href="mailto:Services@crowdstrike.com">Services@crowdstrike.com</a></em></p>

		</div>
	</div>
</div></div></div>			</div><!-- .wpex-vc-columns-wrap -->

		
		
		
	</div>

	
</div><!-- .wpex-vc-row-wrap -->
</div><!-- .entry -->


<div class="wpex-social-share-wrap clr position-horizontal">

	
	<ul class="wpex-social-share position-horizontal style-minimal clr">

		
				<li class="share-twitter">
					<a href="http://twitter.com/share?text=I%20Know%20What%20You%20Did%20Last%20Month%3A%20A%20New%20Artifact%20of%20Execution%20on%20macOS%2010.13&amp;url=http%3A%2F%2Fwww.crowdstrike.com%2Fblog%2Fi-know-what-you-did-last-month-a-new-artifact-of-execution-on-macos-10-13%2F" title="Share on Twitter" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;">
						<span class="fa fa-twitter"></span>
						<span class="social-share-button-text">Tweet</span>
					</a>
				</li>

			
		
				<li class="share-linkedin">
					<a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwww.crowdstrike.com%2Fblog%2Fi-know-what-you-did-last-month-a-new-artifact-of-execution-on-macos-10-13%2F&amp;title=I%20Know%20What%20You%20Did%20Last%20Month%3A%20A%20New%20Artifact%20of%20Execution%20on%20macOS%2010.13&amp;summary=%3Cp%3EIntroduction%20Analysts%20that%20perform%20macOS%20forensics%20have%20had%20few%2C%20if%20any%2C%20artifacts%20of%20program%20execution%20to%20rely%20on%20during%20investigations%20%E2%80%94%20until%20now.%20In%20macOS%2010.13%20%28High%20Sierra%29%2C%20Apple%20introduced%20CoreAnalytics%2C%20which%20is%20a%20system%20diagnostics%20mechanism%20that%20maintains%20a%26hellip%3B%3C%2Fp%3E&amp;source=https://www.crowdstrike.com/blog/" title="Share on LinkedIn" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;">
						<span class="fa fa-linkedin"></span>
						<span class="social-share-button-text">Share</span>
					</a>
				</li>

			
		
	</ul><!-- .wpex-social-share -->

</div><!-- .wpex-social-share-wrap --><a id="tech-center-post-promo" href="https://www.crowdstrike.com/resources/free-trials/try-falcon-prevent/?ctm_source=Website&ctm_medium=Blog&ctm_campaign=Blog-Bottom-Promo">
<img src="/blog/wp-content/img/FreeTrialBlog2.jpg" alt="CrowdStrike Falcon Free Trial" />
</a>

	<div class="related-posts clr">

		
	<div class="theme-heading related-posts-title">
		<span class="text">Related Content</span>
	</div>


		<div class="wpex-row clr">
														
<article class="related-post clr nr-col span_1_of_3 col-1 post-21025 post type-post status-publish format-standard has-post-thumbnail hentry category-from-the-front-lines tag-featured tag-home-feature entry format-video has-media">

	
		<figure class="related-post-figure clr overlay-parent overlay-parent-post">

			<a href="https://www.crowdstrike.com/blog/visit-crowdstrike-at-black-hat-2018/" title="Visit CrowdStrike at Black Hat 2018" rel="bookmark" class="related-post-thumb wpex-image-hover opacity">
				<img src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Black-hat-booth.jpg" width="530" height="349" alt="Black Hat Booth" />							</a><!-- .related-post-thumb -->
					</figure>

	
	
		<div class="related-post-content equal-height-content clr">
			<h4 class="related-post-title">
				<a href="https://www.crowdstrike.com/blog/visit-crowdstrike-at-black-hat-2018/" title="Visit CrowdStrike at Black Hat 2018" rel="bookmark">Visit CrowdStrike at Black Hat 2018</a>
			</h4><!-- .related-post-title -->
			<div class="related-post-excerpt clr">
				<p>CrowdStrike® is excited to join more than 17,000 security experts in Las Vegas this August for&hellip;</p>			</div><!-- related-post-excerpt -->
		</div><!-- .related-post-content -->

	
</article><!-- .related-post -->															
<article class="related-post clr nr-col span_1_of_3 col-2 post-20986 post type-post status-publish format-standard has-post-thumbnail hentry category-from-the-front-lines tag-featured tag-home-feature entry format-video has-media">

	
		<figure class="related-post-figure clr overlay-parent overlay-parent-post">

			<a href="https://www.crowdstrike.com/blog/spark-hot-potato-passing-dataframes-between-scala-spark-and-pyspark/" title="Spark Hot Potato: Passing DataFrames Between Scala Spark and PySpark" rel="bookmark" class="related-post-thumb wpex-image-hover opacity">
				<img src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/07/Python-blog-image.jpg" width="530" height="349" alt="PySpark" />							</a><!-- .related-post-thumb -->
					</figure>

	
	
		<div class="related-post-content equal-height-content clr">
			<h4 class="related-post-title">
				<a href="https://www.crowdstrike.com/blog/spark-hot-potato-passing-dataframes-between-scala-spark-and-pyspark/" title="Spark Hot Potato: Passing DataFrames Between Scala Spark and PySpark" rel="bookmark">Spark Hot Potato: Passing DataFrames Between Scala Spark and PySpark</a>
			</h4><!-- .related-post-title -->
			<div class="related-post-excerpt clr">
				<p>Introduction This blog introduces some of the innovative techniques the CrowdStrike Data Science team is using&hellip;</p>			</div><!-- related-post-excerpt -->
		</div><!-- .related-post-content -->

	
</article><!-- .related-post -->															
<article class="related-post clr nr-col span_1_of_3 col-3 post-20849 post type-post status-publish format-standard has-post-thumbnail hentry category-from-the-front-lines tag-featured tag-home-feature entry format-video has-media">

	
		<figure class="related-post-figure clr overlay-parent overlay-parent-post">

			<a href="https://www.crowdstrike.com/blog/hiding-in-plain-sight-using-the-office-365-activities-api-to-investigate-business-email-compromises/" title="Hiding in Plain Sight: Using the Office 365 Activities API to Investigate Business Email Compromises" rel="bookmark" class="related-post-thumb wpex-image-hover opacity">
				<img src="https://www.crowdstrike.com/blog/wp-content/uploads/2018/06/Hiding-plain-sight-blog.jpg" width="530" height="349" alt="Hiding-plain-sight-blog" />							</a><!-- .related-post-thumb -->
					</figure>

	
	
		<div class="related-post-content equal-height-content clr">
			<h4 class="related-post-title">
				<a href="https://www.crowdstrike.com/blog/hiding-in-plain-sight-using-the-office-365-activities-api-to-investigate-business-email-compromises/" title="Hiding in Plain Sight: Using the Office 365 Activities API to Investigate Business Email Compromises" rel="bookmark">Hiding in Plain Sight: Using the Office 365 Activities API to Investigate Business Email Compromises</a>
			</h4><!-- .related-post-title -->
			<div class="related-post-excerpt clr">
				<p>Update: While this blog post originally covered the Office 365 Activities API, that functionality has been&hellip;</p>			</div><!-- related-post-excerpt -->
		</div><!-- .related-post-content -->

	
</article><!-- .related-post -->									</div><!-- .wpex-row -->

	</div><!-- .related-posts -->



</article><!-- .entry -->

				
			</div><!-- #content -->

			
		</div><!-- #primary -->

		

<aside id="sidebar" class="sidebar-container sidebar-primary">

	
	<div id="sidebar-inner" class="clr">

		<div class="sidebar-box widget_categories clr"><h4 class="widget-title">Categories</h4>		<ul>
	<li class="cat-item cat-item-6"><a href="https://www.crowdstrike.com/blog/category/endpoint-protection/" title="Endpoint Protection

&nbsp;">Endpoint Protection</a> <span class="cat-count-span">(117)
</li>
	<li class="cat-item cat-item-222"><a href="https://www.crowdstrike.com/blog/category/executive-viewpoint/" title="Executive Viewpoint

">Executive Viewpoint</a> <span class="cat-count-span">(68)
</li>
	<li class="cat-item cat-item-4"><a href="https://www.crowdstrike.com/blog/category/from-the-front-lines/" title="From The Front Lines

&nbsp;">From The Front Lines</a> <span class="cat-count-span">(65)
</li>
	<li class="cat-item cat-item-7"><a href="https://www.crowdstrike.com/blog/category/threat-intel-research/" title="Research &amp; Threat Intel

">Research &amp; Threat Intel</a> <span class="cat-count-span">(117)
</li>
	<li class="cat-item cat-item-245"><a href="https://www.crowdstrike.com/blog/category/tech-center/" title="Tech Center">Tech Center</a> <span class="cat-count-span">(29)
</li>
		</ul>
</div><div class="sidebar-box widget_wpex_recent_posts_thumb clr">
		<ul class="wpex-widget-recent-posts wpex-clr style-fullimg">

			
		</ul><!-- .wpex-widget-recent-posts -->

				
		</div><div class="sidebar-box widget_wpex_fontawesome_social_widget clr"><h4 class="widget-title">CONNECT WITH US</h4>
			<div class="wpex-fa-social-widget clr">
								<ul style="font-size:14px;">
					<li>
								<a href="https://twitter.com/CrowdStrike" title="Twitter" class="wpex-twitter wpex-social-btn wpex-social-btn-flat wpex-social-bg" style="height:20px;width:20px;line-height:20px;border-radius:0px;" target="_blank"><span class="fa fa-twitter"></span>
								</a>
							</li><li>
								<a href="https://www.facebook.com/CrowdStrike" title="Facebook" class="wpex-facebook wpex-social-btn wpex-social-btn-flat wpex-social-bg" style="height:20px;width:20px;line-height:20px;border-radius:0px;" target="_blank"><span class="fa fa-facebook"></span>
								</a>
							</li><li>
								<a href="https://plus.google.com/101967380457820256808/posts" title="GooglePlus" class="wpex-google-plus wpex-social-btn wpex-social-btn-flat wpex-social-bg" style="height:20px;width:20px;line-height:20px;border-radius:0px;" target="_blank"><span class="fa fa-google-plus"></span>
								</a>
							</li><li>
								<a href="https://www.linkedin.com/company/crowdstrike" title="LinkedIn" class="wpex-linkedin wpex-social-btn wpex-social-btn-flat wpex-social-bg" style="height:20px;width:20px;line-height:20px;border-radius:0px;" target="_blank"><span class="fa fa-linkedin"></span>
								</a>
							</li><li>
								<a href="https://www.youtube.com/user/CrowdStrike" title="Youtube" class="wpex-youtube wpex-social-btn wpex-social-btn-flat wpex-social-bg" style="height:20px;width:20px;line-height:20px;border-radius:0px;" target="_blank"><span class="fa fa-youtube-play"></span>
								</a>
							</li><li>
								<a href="https://www.crowdstrike.com/blog/feed" title="RSS" class="wpex-rss wpex-social-btn wpex-social-btn-flat wpex-social-bg" style="height:20px;width:20px;line-height:20px;border-radius:0px;" target="_blank"><span class="fa fa-rss"></span>
								</a>
							</li>				</ul>
			</div><!-- .fontawesome-social-widget -->

			</div>
		<div class="widget_text sidebar-box widget_custom_html clr"><div class="textwidget custom-html-widget"><a href="https://www.crowdstrike.com/resources/free-trials/try-falcon-prevent/?ctm_source=Website&ctm_medium=Blog&ctm_campaign=Blog-Side-Promo">
<img src="/blog/wp-content/img/FreeTrialBlog1.jpg" alt="CrowdStrike Falcon Free Trial" />
</a></div></div>		<div class="sidebar-box widget_recent_entries clr">		<h4 class="widget-title">Featured Articles</h4>		<ul>
											<li>
					<a href="https://www.crowdstrike.com/blog/meet-crowdstrikes-adversary-of-the-month-for-july-wicked-spider/">Meet CrowdStrike’s Adversary of the Month for July: WICKED SPIDER</a>
											<span class="post-date">July 26, 2018</span>
									</li>
											<li>
					<a href="https://www.crowdstrike.com/blog/why-cybersecurity-should-be-a-board-level-discussion/">Why Cybersecurity Should be a Board-Level Discussion</a>
											<span class="post-date">July 25, 2018</span>
									</li>
											<li>
					<a href="https://www.crowdstrike.com/blog/i-know-what-you-did-last-month-a-new-artifact-of-execution-on-macos-10-13/">I Know What You Did Last Month: A New Artifact of Execution on macOS 10.13</a>
											<span class="post-date">July 24, 2018</span>
									</li>
											<li>
					<a href="https://www.crowdstrike.com/blog/global-survey-reveals-supply-chain-as-a-rising-and-critical-new-threat-vector/">Global Survey Reveals Supply Chain as a Rising and Critical New Threat Vector</a>
											<span class="post-date">July 23, 2018</span>
									</li>
					</ul>
		</div><div class="sidebar-box widget_text clr">			<div class="textwidget"><div class="textcenter bg-red pad-box20">
<h2 class="white section-header">SUBSCRIBE</h2>
<p class="white">Sign up now to receive the latest notifications and updates from CrowdStrike.</p>
<p><a id="modal-trigger" class="btn btn-bordered border-white bg-red white wpex-lightbox">SIGN UP</a></p>
</div></div>
		</div><div class="sidebar-box widget_text clr">			<div class="textwidget"><div id="demo-sidebar-promo" class="textcenter pad-box20" style="overflow:hidden; position:relative; background-color:#efefef;">
<span><i class="red cs-icon-cs-icon" style="font-size:100px;margin-top:-20px;"></i></span>
<h3 class="grey section-header">See CrowdStrike Falcon in Action</h3>
<p class="grey">Detect, prevent, and respond to attacks— even malware-free intrusions—at any stage, with next-generation endpoint protection.</p>
<p><a class="btn btn-bordered border-white bg-red white" href="https://www.crowdstrike.com/see-demo/">SEE DEMO</a></p>
</div></div>
		</div>
	</div><!-- #sidebar-inner -->

	
</aside><!-- #sidebar -->


	</div><!-- .container -->


            

	<div class="post-pagination-wrap clr">

		<ul class="post-pagination container clr">

			
				<li class="post-prev"><a href="https://www.crowdstrike.com/blog/visit-crowdstrike-at-black-hat-2018/" rel="prev"><span class="fa fa-angle-double-left"></span>Visit CrowdStrike at Black Hat 2018</a></li>

			
						
		</ul><!-- .post-post-pagination -->

	</div><!-- .post-pagination-wrap -->


        </main><!-- #main-content -->                
        
        

	
		<div id="footer-builder" class="footer-builder clr">
			<div class="footer-builder-content clr container">
							</div><!-- .footer-builder-content -->
		</div><!-- .footer-builder -->

	

    </div><!-- #wrap -->

    
</div><!-- .outer-wrap -->



<div id="mobile-menu-alternative" class="wpex-hidden">
    <div class="menu-mobile-main-menu-container"><ul id="menu-mobile-main-menu" class="dropdown-menu"><li id="menu-item-16715" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16715"><a href="https://www.crowdstrike.com/blog/recent-articles/">Recent Articles</a></li>
<li id="menu-item-16722" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16722"><a href="https://www.crowdstrike.com/blog/featured-articles/">Featured Articles</a></li>
<li id="menu-item-16728" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16728"><a href="https://www.crowdstrike.com/blog/videos/">Videos</a></li>
<li id="menu-item-16705" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16705"><a href="/blog/categories-overview/">Categories</a></li>
<li id="menu-item-16758" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16758"><a href="https://www.crowdstrike.com/see-demo/">See Demo</a></li>
<li id="menu-item-16760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16760"><a href="https://www.crowdstrike.com/request-info/">Request Info</a></li>
<li id="menu-item-16903" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16903"><a href="https://www.crowdstrike.com">CrowdStrike Main Site</a></li>
</ul></div></div><!-- #mobile-menu-alternative -->
<a href="#" id="site-scroll-top"><span class="fa fa-chevron-up"></span></a>	<script type='text/javascript' src='https://www.crowdstrike.com/blog/wp-content/themes/CrowdStrike_Blog/js/jquery.prettyPhoto.js?ver=1.0.0' defer onload=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpexLocalize = {"isRTL":"","mainLayout":"full-width","menuSearchStyle":"disabled","siteHeaderStyle":"one","superfishDelay":"600","superfishSpeed":"fast","superfishSpeedOut":"fast","mobileMenuBreakpoint":"960","mobileMenuStyle":"toggle","mobileMenuToggleStyle":"icon_buttons","localScrollUpdateHash":"1","localScrollSpeed":"800","windowScrollTopSpeed":"800","carouselSpeed":"150","customSelects":".woocommerce-ordering .orderby, #dropdown_product_cat, .widget_categories select, .widget_archive select, #bbp_stick_topic_select, #bbp_topic_status_select, #bbp_destination_topic, .single-product .variations_form .variations select","milestoneDecimalFormat":",","hasStickyHeader":"1","stickyHeaderStyle":"standard","hasStickyMobileHeader":"","overlayHeaderStickyTop":"0","stickyHeaderBreakPoint":"960","animateMobileToggle":"1","stickyTopBarBreakPoint":"960","hasStickyTopBarMobile":"1","iLightbox":{"auto":false,"skin":"smooth","path":"horizontal","controls":{"arrows":true,"thumbnail":false,"fullscreen":true,"mousewheel":false},"effects":{"loadedFadeSpeed":50,"fadeSpeed":500},"show":{"title":false,"speed":200},"hide":{"speed":200},"overlay":{"blur":true,"opacity":0.9},"social":{"start":true,"show":"mouseenter","hide":"mouseleave","buttons":false}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.crowdstrike.com/blog/wp-content/themes/Total/js/total-min.js?ver=3.4.0' defer onload=''></script>
<script type='text/javascript' src='//maps.googleapis.com/maps/api/js?ver=4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ubermenu_data = {"remove_conflicts":"on","reposition_on_load":"off","intent_delay":"300","intent_interval":"100","intent_threshold":"7","scrollto_offset":"50","scrollto_duration":"1000","responsive_breakpoint":"959","accessible":"on","retractor_display_strategy":"responsive","touch_off_close":"on","collapse_after_scroll":"on","v":"3.2.4","configurations":["main"],"ajax_url":"https:\/\/www.crowdstrike.com\/blog\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/www.crowdstrike.com\/blog\/wp-content\/plugins\/ubermenu\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.crowdstrike.com/blog/wp-content/plugins/ubermenu/assets/js/ubermenu.min.js?ver=3.2.4' defer onload=''></script>
<script type='text/javascript' src='https://www.crowdstrike.com/blog/wp-includes/js/wp-embed.min.js?ver=4.9' defer onload=''></script>
<script type='text/javascript' src='https://www.crowdstrike.com/blog/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=4.11.1' defer onload=''></script>
<div id="stickyfooterwrapper">
    <div class="pageStickyFooter">
        <div style="display: none;">&nbsp;</div>
    </div>
    <div class="pageStickyFooterText">
        <div class="text-wrap">
            <p class="batman caps red">Try CrowdStrike Free for 15 Days <a class="btn btn-large bg-red white hover-to-red" id="stickyfooter-see-demo">Get Started with A Free Trial</a></p>
        </div>
    </div>
    <div id="footer-form-modal-wrap" style="display: none;">
        <p class="textcenter white karla-regular"><a class="karla-bold red" id="close-footer-form" style="display: none;">X</a></p>
        <iframe id="footer-form-frame" height="490" width="800" src="https://go.crowdstrike.com/WF-Trial-to-Pay_LP-Registration-Footer.html"></iframe>
    </div>
</div>

<div id="footer-lower">
    <div class="page-section">
        <span class="footer-logo"><a href="/"><object type="image/svg+xml" data="/wp-content/img/cs-logo.svg" height="40"></object></a></span>
        <ul class="social-links">
            <li class="circle-icon-outline"><a href="https://twitter.com/CrowdStrike" rel="noreferrer" target="_blank"><i class="fa fa-twitter"></i></a></li>
            <li class="circle-icon-outline"><a href="https://www.facebook.com/CrowdStrike/" rel="noreferrer" target="_blank"><i class="fa fa-facebook"></i></a></li>
            <li class="circle-icon-outline"><a href="https://plus.google.com/101967380457820256808/posts" rel="noreferrer" target="_blank"><i class="fa fa-google-plus"></i></a></li>
            <li class="circle-icon-outline"><a href="https://www.linkedin.com/company/crowdstrike" rel="noreferrer" target="_blank"><i class="fa fa-linkedin"></i></a></li>
            <li class="circle-icon-outline"><a href="http://www.youtube.com/user/CrowdStrike" rel="noreferrer" target="_blank"><i class="fa fa-youtube-play"></i></a></li>
        </ul>
        <hr>
        <ul id="footer-lower-links">
            <li id="footer-copyright">Copyright © 2018 CrowdStrike</li>
            <li><a href="/privacy-notice/">Privacy</a></li>
            <li><a href="/request-information/">Request Info</a></li>
            <li><a href="/blog">Blog</a></li>
            <li><a href="/join-our-team/">Join Our Team</a></li>
            <li><a href="/sitemap/">Sitemap</a></li>
            <li><a href="/contact-us/">Contact Us</a></li>
            <li>1.888.512.8906</li>
        </ul>

        <div id="footer-lang-links">
            <a class="top-level" href="/">English</a>
            <div class="expandable-footer-languages">
                <ul class="footer-language-list"><li><a target="_blank" href="/sites/es/">Espa&ntilde;ol</a></li><li><a target="_blank" href="/sites/it/">Italiano</a></li><li><a target="_blank" href="/sites/fr/">Fran&ccedil;ais</a></li><li><a target="_blank" href="/sites/de/">Deutsch</a></li><li><a target="_blank" href="/sites/jp/">日本語</a></li></ul>
            </div>
        </div>
    </div>
</div>

<script type="text/javascript">
function detectmob() {
    if( navigator.userAgent.match(/Android/i)
    || navigator.userAgent.match(/webOS/i)
    || navigator.userAgent.match(/iPhone/i)
    || navigator.userAgent.match(/iPad/i)
    || navigator.userAgent.match(/iPod/i)
    || navigator.userAgent.match(/BlackBerry/i)
    || navigator.userAgent.match(/Windows Phone/i)
    ) { 
        return true;
    }   
    else {
        return false;
    }   
}

    $(document).ready(function() {
        var mobilecheck = detectmob();
        if (!(mobilecheck)) {
            $('#stickyfooter-free-trial').click(function() {
                 ga('send', {
                    hitType: 'event',
                    eventCategory: 'Sticky Footer',
                    eventAction: 'Free Trial',
                    eventLabel: 'Blog - Free Trial'
                });
            });

            $('a#footer-request-info').click(function() {
                ga('send', {
                    hitType: 'event',
                    eventCategory: 'Sticky Footer',
                    eventAction: 'Blog - Request Info',
                    eventLabel: 'Blog - Request Info'
                });
            });
            $('a#footer-exp-breach').click(function() {
                ga('send', {
                    hitType: 'event',
                    eventCategory: 'Sticky Footer',
                    eventAction: 'Blog - Experienced Breach',
                    eventLabel: 'Blog - Experienced Breach'
                });
            });
        } else {
            $('#stickyfooter-free-trial').click(function() {
                 ga('send', {
                    hitType: 'event',
                    eventCategory: 'Mobile Sticky Footer',
                    eventAction: 'Free Trial',
                    eventLabel: 'Blog - Free Trial'
                });
            });

            $('a#footer-request-info').click(function() {
                ga('send', {
                    hitType: 'event',
                    eventCategory: 'Mobile Sticky Footer',
                    eventAction: 'Blog - Request Info',
                    eventLabel: 'Blog - Request Info'
                });
            });
            $('a#footer-exp-breach').click(function() {
                ga('send', {
                    hitType: 'event',
                    eventCategory: 'Mobile Sticky Footer',
                    eventAction: 'Blog - Experienced Breach',
                    eventLabel: 'Blog - Experienced Breach'
                });
            });
        }
    });
</script>

<script type="text/javascript">
$(document).ready(function() {
    setTimeout(function(){
      document.getElementById('addsearchfield').setAttribute('placeholder','Search');
      document.getElementById('mobileaddsearchfield').setAttribute('placeholder','Search');
    }, 1000);
    $('.cs-search-icon' ).click(function() {
          if (!$('.search-wrapper').hasClass('showing')) {
            $('.search-wrapper').addClass('showing').show();
          }
          else {
            $('.search-wrapper').removeClass('showing').hide();
          }
    });
});
</script>

<style>
    div#liveagent-chat-container {
        position: fixed;
        bottom: 20px;
        right: 35px;
    }   
    input.addsearch {
        height: 25px;
        position: absolute;
        right: 180px;
    }   
    li#menu-item-23537 {
        position: absolute;
        right: 400px;
    }
    img.cs-search-icon {
        cursor: pointer;
    }
</style>
<script type="text/javascript" src="https://addsearch.com/js/?key=7737a29b854de71521b1cd72c4118cfc"></script>

<script type="application/javascript" src="/wp-content/custom_js/set-utm-cookies.js"></script>
<script type="application/javascript" src="/wp-content/custom_js/set-ctm-cookies.js"></script>
<script type="application/javascript" src="/wp-content/custom_js/retrieve-utm-cookies.js"></script>
<script type="application/javascript" src="/wp-content/custom_js/retrieve-ctm-cookies.js"></script>
<script type="application/javascript" src="/wp-content/custom_js/event_tracking.js"></script>
</body>
</html>
